Bug 76238 - up2date does not report install problems when run interactively
up2date does not report install problems when run interactively
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-18 11:44 EDT by Need Real Name
Modified: 2015-01-07 19:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-20 15:50:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-18 11:44:44 EDT
Description of Problem:

While installing a recent kernel errata, we ran into a situation where the lilo
step failed.  This was only reported to the /var/log/up2date log file, and not
to the screen.  Every indication was that the operation was successful and that
nothing had failed.

Version-Release number of selected component (if applicable):

up2date-2.8.39-1.7.2

How Reproducible:

None of the systems that had this problem logged any output to the screen when
run interactively.

Steps to Reproduce:
1. install the 2.4.18-17.7.xsmp kernel
2. observe that up2date installation appears successful
3. note that the lilo run failed, but that it is only visible in the log file

Actual Results:

The up2date operation appeared to run successfully with no errors.

Expected Results:

If a step of up2date fails, I would expect to see the output on the screen when
being run from a terminal.

Additional Information:
Comment 1 Adrian Likins 2002-11-04 16:56:03 EST
I'll take a look for the next errata...
Comment 2 Adrian Likins 2002-11-04 17:42:52 EST
Hmm, from glancing though the code, it looks like there
should at least be a warning dialog presented in the gui mode,
and a warning message and a 1 exit status presented in cli
mode.

But on a second look, that seems to only happen on a lilo
box. Which is busted, but then you mentioned these boxes
were using lilo.

What error message got left in the log file?

Comment 3 Need Real Name 2002-11-05 00:17:39 EST
[Thu Oct 17 17:10:14 2002] up2date Adding packages to package profile:
['kernel-2.4.18-17.7.x', 'kernel-smp-2.4.18-17.7.x']
[Thu Oct 17 17:10:18 2002] up2date deleting
/var/spool/up2date/kernel-2.4.18-17.7.x.i686.hdr
[Thu Oct 17 17:10:18 2002] up2date deleting
/var/spool/up2date/kernel-2.4.18-17.7.x.i686.rpm
[Thu Oct 17 17:10:18 2002] up2date deleting
/var/spool/up2date/kernel-smp-2.4.18-17.7.x.i686.hdr
[Thu Oct 17 17:10:18 2002] up2date deleting
/var/spool/up2date/kernel-smp-2.4.18-17.7.x.i686.rpm
[Thu Oct 17 17:10:18 2002] up2date Modifying bootloader config to include the
new kernel info
[Thu Oct 17 17:10:18 2002] up2date Adding 2.4.18-17.7.x to bootloader config
[Thu Oct 17 17:10:18 2002] up2date Adding 2.4.18-17.7.xsmp to bootloader config
[Thu Oct 17 17:10:18 2002] up2date Running lilo with the new configuration
[Thu Oct 17 17:10:18 2002] up2date Opening rpmdb in /var/lib/rpm/ with option 0
[Thu Oct 17 17:10:18 2002] up2date Running "/sbin/mkinitrd --ifneeded
/boot/initrd-2.4.18-17.7.x.img 2.4.18-17.7.x" 
[Thu Oct 17 17:10:18 2002] up2date /boot/initrd-2.4.18-17.7.x.img was created
[Thu Oct 17 17:10:18 2002] up2date renaming the lilo.conf entry for linux-up to
linux-up.bak1
[Thu Oct 17 17:10:19 2002] up2date Running "/sbin/mkinitrd --ifneeded
/boot/initrd-2.4.18-17.7.xsmp.img 2.4.18-17.7.xsmp" 
[Thu Oct 17 17:10:19 2002] up2date /boot/initrd-2.4.18-17.7.xsmp.img was created
[Thu Oct 17 17:10:19 2002] up2date renaming the lilo.conf entry for linux to
linux.bak1
[Thu Oct 17 17:10:19 2002] up2date making a backup copy of /etc/lilo.conf as
/etc/lilo.conf.up2date-1034889019.15
[Thu Oct 17 17:10:19 2002] up2date writing out the new /etc/lilo.conf
[Thu Oct 17 17:10:19 2002] up2date Running " /sbin/lilo -t -r /"  (lilo test mode)
[Thu Oct 17 17:10:19 2002] up2date restoring the backup file
/etc/lilo.conf.up2date-1034889019.15 to /etc/lilo.conf
[Thu Oct 17 17:10:19 2002] up2date Error installing lilo.conf  The message was:
test install of lilo failed
Comment 4 Adrian Likins 2004-08-20 15:50:23 EDT
belive the lilo issues should all be squared away now, 
that and default use of grub, so closing currentrelease

Note You need to log in before you can comment on or make changes to this bug.