Bug 762468 - (GLUSTER-736) [NFS] Dbench fails with Distribute+Replicate
[NFS] Dbench fails with Distribute+Replicate
Status: CLOSED WORKSFORME
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
nfs-alpha
All Linux
low Severity medium
: ---
: ---
Assigned To: Shehjar Tikoo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-18 05:52 EDT by Anush Shetty
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTNR
Mount Type: nfs
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2010-03-18 05:52:05 EDT
Dbench exits with an error with an 'Unknown error' on a Distribute+Replicate setup with all the performance translators except Statprefetch.

bash-3.2# dbench -s 10
dbench version 4.00 - Copyright Andrew Tridgell 1999-2004

Running for 600 seconds with load '/usr/local/share/client.txt' and minimum warmup 120 secs
10 of 10 processes prepared for launch   0 sec
releasing clients
   9        23     5.75 MB/sec  warmup   1 sec  latency 72.569 ms
  10        37     6.94 MB/sec  warmup   2 sec  latency 399.671 ms
  10        60     8.49 MB/sec  warmup   3 sec  latency 333.105 ms
  10        77     8.60 MB/sec  warmup   4 sec  latency 241.249 ms
  10        90     8.09 MB/sec  warmup   5 sec  latency 312.021 ms
  10       104     7.94 MB/sec  warmup   6 sec  latency 527.311 ms
  10       115     7.54 MB/sec  warmup   7 sec  latency 645.990 ms
  10       130     7.20 MB/sec  warmup   8 sec  latency 669.669 ms
  10       155     7.20 MB/sec  warmup   9 sec  latency 226.276 ms
  10       173     7.01 MB/sec  warmup  10 sec  latency 239.231 ms
  10       191     6.94 MB/sec  warmup  11 sec  latency 476.108 ms
  10       210     6.84 MB/sec  warmup  12 sec  latency 513.792 ms
  10       228     6.74 MB/sec  warmup  13 sec  latency 352.793 ms
  10       240     6.54 MB/sec  warmup  14 sec  latency 533.419 ms
  10       261     6.56 MB/sec  warmup  15 sec  latency 314.792 ms
  10       276     6.45 MB/sec  warmup  16 sec  latency 347.914 ms
  10       296     6.42 MB/sec  warmup  17 sec  latency 505.699 ms
  10       312     6.34 MB/sec  warmup  18 sec  latency 358.329 ms
[313] open ./clients/client4/~dmtmp/PM failed for handle 9972 (Unknown error 526)
(314) ERROR: handle 9972 was not found
Child failed with status 1
Comment 1 Shehjar Tikoo 2010-07-04 02:16:39 EDT
Cautionary note, this could be the same problems as that in bz 937.
Comment 2 Shehjar Tikoo 2010-07-22 05:35:37 EDT
Not able to reproduce with rc10, with and without the fix for 937. Closing.

Note You need to log in before you can comment on or make changes to this bug.