Bug 762517 - (GLUSTER-785) Iozone fails with "Error reading block" and "No such file or directory" on NFS
Iozone fails with "Error reading block" and "No such file or directory" on NFS
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
nfs-alpha
All Linux
low Severity medium
: ---
: ---
Assigned To: Shehjar Tikoo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-29 14:22 EDT by Shehjar Tikoo
Modified: 2015-12-01 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTNR
Mount Type: nfs
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shehjar Tikoo 2010-03-29 14:22:22 EDT
As reported by user on nfs-alpha@gluster:

> I have tested the Alpha release on my server Side configuration with 4 
> servers in replication et distribution mod.
> Replication and distribution is working, but when I do some benchmark 
> with IOZone, I got some errors :
> 
> Error reading block 0, fd= 3
> 
> Error reading block 0, fd= 3
> 
> /users/mount_nfs/IOzone452.tmp: No such file or directory
> 
> /users/mount_nfs/IOzone451.tmp: No such file or directory
> 
> iozone: interrupted
Comment 1 Shehjar Tikoo 2010-04-20 23:59:51 EDT
The initial problem reported by the user was due to a crashed NFS server. That bug, bz 757, was fixed. IOW, this exact problem was just a symptom of the actual problem in the server and will not occur anymore.

Note You need to log in before you can comment on or make changes to this bug.