Bug 762549 - (GLUSTER-817) [NFS] Kernel & GCC Compile on distribute failed
[NFS] Kernel & GCC Compile on distribute failed
Status: CLOSED DUPLICATE of bug 762489
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
All Linux
low Severity medium
: ---
: ---
Assigned To: Shehjar Tikoo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-12 00:41 EDT by Anush Shetty
Modified: 2015-12-01 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTNR
Mount Type: nfs
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2010-04-12 00:41:39 EDT
Crash while running Kernel Compile and GCC compliation from the NFS Client over 4 distributes. 

(gdb) bt
#0  0x00002aaaab1440d2 in pthread_spin_lock () from /lib64/libpthread.so.0
#1  0x00002aaaaacf7013 in mem_put (pool=0x2aaaabf2b900, ptr=0x2aaab0f7d4b0) at mem-pool.c:166
#2  0x00002aaaac588caf in nfs3svc_getattr_lookup_cbk (frame=<value optimized out>, cookie=<value optimized out>, this=<value optimized out>, 
    op_ret=<value optimized out>, op_errno=117, inode=<value optimized out>, buf=0x2aaab0f7d968, xattr=0x1158dc0, postparent=0x2aaab0f7db70) at nfs3.c:418
#3  0x00002aaaac5782dd in nfs_fop_lookup_cbk (frame=0x2aaab0e5df48, cookie=0x615310, this=0x614100, op_ret=0, op_errno=117, inode=0x616f70, 
    buf=0x2aaab0f7d968, xattr=0x1158dc0, postparent=0x2aaab0f7db70) at nfs-fops.c:237
#4  0x00002aaaaace3f9d in default_lookup_cbk (frame=0x2aaab0e87fb0, cookie=<value optimized out>, this=<value optimized out>, op_ret=0, op_errno=117, 
    inode=0x616f70, buf=0x2aaab0f7d968, dict=0x1158dc0, postparent=0x2aaab0f7db70) at defaults.c:47
#5  0x00002aaaac156323 in dht_revalidate_cbk (frame=0x2aaab0e88030, cookie=0x2aaab0e5e5f0, this=0x612e50, op_ret=<value optimized out>, 
    op_errno=<value optimized out>, inode=<value optimized out>, stbuf=0x7fff876044d0, xattr=0x116fca0, postparent=0x7fff87604460) at dht-common.c:320
#6  0x00002aaaabf2d8cf in client_lookup_cbk (frame=0x2aaab0e5e5f0, hdr=<value optimized out>, hdrlen=<value optimized out>, iobuf=<value optimized out>)
    at client-protocol.c:4716
#7  0x00002aaaabf191ca in protocol_client_pollin (this=0x612140, trans=0x617fe0) at client-protocol.c:6391
#8  0x00002aaaabf27982 in notify (this=0x2aaaabf2b918, event=2, data=0x617fe0) at client-protocol.c:6510
#9  0x00002aaaaacdb433 in xlator_notify (xl=0x612140, event=2, data=0x617fe0) at xlator.c:919
#10 0x00002aaaac9be06b in socket_event_handler (fd=<value optimized out>, idx=7, data=0x617fe0, poll_in=1, poll_out=0, poll_err=0) at socket.c:831
#11 0x00002aaaaacf64e5 in event_dispatch_epoll (event_pool=0x60a8b0) at event.c:804
#12 0x0000000000404387 in main (argc=7, argv=0x7fff87605428) at glusterfsd.c:1482

NFS log:
patchset: git://git.sv.gnu.org/gluster.git
signal received: 11
time of crash: 2010-04-11 04:02:04
configuration details:
argp 1
backtrace 1
dlfcn 1
fdatasync 1
libpthread 1
llistxattr 1
setfsid 1
spinlock 1
epoll.h 1
xattr.h 1
st_atim.tv_nsec 1
package-string: glusterfs 3.0.0git
[2010-04-11 04:02:04] T [rpcsvc.c:2407:__rpcsvc_conn_data_poll_out] rpc-service: First Tx Buf
[2010-04-11 04:02:04] T [rpcsvc.c:2418:__rpcsvc_conn_data_poll_out] rpc-service: conn: 0x61c4b0, Tx request: 28, Tx sent: 28
[2010-04-11 04:02:04] T [rpcsvc.c:2414:__rpcsvc_conn_data_poll_out] rpc-service: Last Tx Buf
[2010-04-11 04:02:04] T [rpcsvc.c:2418:__rpcsvc_conn_data_poll_out] rpc-service: conn: 0x61c4b0, Tx request: 88, Tx sent: 88
/lib64/libc.so.6[0x2aaaab385280]
/lib64/libpthread.so.0(pthread_spin_lock+0x2)[0x2aaaab1440d2]
/opt/glusterfs/gnfs/lib/libglusterfs.so.0(mem_put+0x33)[0x2aaaaacf7013]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/xlator/nfs/server.so(nfs3svc_getattr_lookup_cbk+0x4f)[0x2aaaac588caf]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/xlator/nfs/server.so(nfs_fop_lookup_cbk+0xbd)[0x2aaaac5782dd]
/opt/glusterfs/gnfs/lib/libglusterfs.so.0[0x2aaaaace3f9d]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/xlator/cluster/distribute.so(dht_revalidate_cbk+0x233)[0x2aaaac156323]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/xlator/protocol/client.so(client_lookup_cbk+0x7bf)[0x2aaaabf2d8cf]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/xlator/protocol/client.so(protocol_client_pollin+0xca)[0x2aaaabf191ca]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/xlator/protocol/client.so(notify+0x212)[0x2aaaabf27982]
/opt/glusterfs/gnfs/lib/libglusterfs.so.0(xlator_notify+0x43)[0x2aaaaacdb433]
/opt/glusterfs/gnfs/lib/glusterfs/3.0.0git/transport/socket.so(socket_event_handler+0xcb)[0x2aaaac9be06b]
/opt/glusterfs/gnfs/lib/libglusterfs.so.0[0x2aaaaacf64e5]
/opt/glusterfs/gnfs/sbin/glusterfs(main+0xb27)[0x404387]
/lib64/libc.so.6(__libc_start_main+0xf4)[0x2aaaab372974]
/opt/glusterfs/gnfs/sbin/glusterfs[0x4027b9]

Complete log /share/tickets/bugid
Comment 1 Shehjar Tikoo 2010-04-12 18:54:30 EDT
The following fix in NFS beta tree fixes this problem:
http://git.gluster.com/?p=users/shehjart/gluster-nfs-beta.git/.git;a=commit;h=8e786138cab3d35c53d5bfdcfc861785834dfb7e

Will be merged back into mainline after beta has been released. Leaving open till then.
Comment 2 Shehjar Tikoo 2010-04-20 23:02:07 EDT

*** This bug has been marked as a duplicate of bug 757 ***

Note You need to log in before you can comment on or make changes to this bug.