Bug 762590 - (GLUSTER-858) Crash with afr_local_cleanup
Crash with afr_local_cleanup
Status: CLOSED DUPLICATE of bug 762587
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
nfs-alpha
All Linux
medium Severity medium
: ---
: ---
Assigned To: Shehjar Tikoo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 08:56 EDT by Anush Shetty
Modified: 2015-12-01 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTNR
Mount Type: nfs
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2010-04-26 08:56:57 EDT
Got this core while running dbench on an Dist-Replicate setup with error-gen below NFS Xlator

(gdb) bt
#0  0x00007f6bfd9ab4b5 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#1  0x00007f6bfd9aef50 in *__GI_abort () at abort.c:92
#2  0x00007f6bfd9a4481 in *__GI___assert_fail (assertion=0x7f6bfe15789e "inode->ref", file=<value optimized out>, line=356, 
    function=0x7f6bfe157ae0 "__inode_unref") at assert.c:81
#3  0x00007f6bfe1339d1 in __inode_unref (inode=0x7f6bec01b390) at inode.c:356
#4  0x00007f6bfe133ab1 in inode_unref (inode=0x7f6bec01b390) at inode.c:395
#5  0x00007f6bfe122419 in loc_wipe (loc=0xebd120) at xlator.c:986
#6  0x00007f6bfccf2626 in afr_local_cleanup (local=0xebd0f0, this=0xe8b7d0) at afr.c:334
#7  0x00007f6bfcd09c54 in afr_unlink_done (frame=0xf57198, this=0xe8b7d0) at afr-dir-write.c:1723
#8  0x00007f6bfcd1aa0a in afr_unlock_common_cbk (frame=0xf57198, cookie=0x7f6bec00ec70, this=0xe8b7d0, op_ret=0, op_errno=0) at afr-transaction.c:514
#9  0x00007f6bfcf6c1aa in client_entrylk_cbk (frame=0x7f6bec00ec70, hdr=0x7f6bec018da0, hdrlen=108, iobuf=0x0) at client-protocol.c:5073
#10 0x00007f6bfcf6ede6 in protocol_client_interpret (this=0xe87880, trans=0xe94350, hdr_p=0x7f6bec018da0 "", hdrlen=108, iobuf=0x0)
    at client-protocol.c:6093
#11 0x00007f6bfcf6fb67 in protocol_client_pollin (this=0xe87880, trans=0xe94350) at client-protocol.c:6391
#12 0x00007f6bfcf70160 in notify (this=0xe87880, event=2, data=0xe94350) at client-protocol.c:6510
#13 0x00007f6bfe1221c8 in xlator_notify (xl=0xe87880, event=2, data=0xe94350) at xlator.c:919
#14 0x00007f6bfb9c845a in socket_event_poll_in (this=0xe94350) at socket.c:731
#15 0x00007f6bfb9c878d in socket_event_handler (fd=9, idx=1, data=0xe94350, poll_in=1, poll_out=0, poll_err=0) at socket.c:831
#16 0x00007f6bfe149736 in event_dispatch_epoll_handler (event_pool=0xe82310, events=0xe96570, i=1) at event.c:804
#17 0x00007f6bfe149928 in event_dispatch_epoll (event_pool=0xe82310) at event.c:867
#18 0x00007f6bfe149c47 in event_dispatch (event_pool=0xe82310) at event.c:975
#19 0x0000000000406cb0 in main (argc=7, argv=0x7fffaa7024f8) at glusterfsd.c:1494


Core in /share/tickets/bugid
Comment 1 Shehjar Tikoo 2010-05-04 03:28:44 EDT
error-gen is being run with the option: failure 5

dbench is run as: while [true]; do dbench -s 10; done
inside the nfs mount point to force is to continue running over and over again even when error gen has caused it to exit with errors.
Comment 2 Shehjar Tikoo 2010-05-05 01:22:24 EDT

*** This bug has been marked as a duplicate of bug 857 ***
Comment 3 Anand Avati 2010-05-05 04:36:04 EDT
PATCH: http://patches.gluster.com/patch/3217 in master (nfs3: Fix NFSv3 string error for EISDIR)
Comment 4 Shehjar Tikoo 2010-05-14 00:13:20 EDT
Re-opened because 857 turned out to be unrelated to NFS.
Comment 5 Shehjar Tikoo 2010-05-14 00:14:42 EDT

*** This bug has been marked as a duplicate of bug 855 ***

Note You need to log in before you can comment on or make changes to this bug.