Bug 762611 - (GLUSTER-879) Crash in afr_local_cleanup
Crash in afr_local_cleanup
Status: CLOSED DUPLICATE of bug 762587
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
nfs-beta
All Linux
low Severity medium
: ---
: ---
Assigned To: Shehjar Tikoo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-03 01:42 EDT by Anush Shetty
Modified: 2015-12-01 11:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTP
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2010-05-03 01:42:25 EDT
While running mixed tests over the NFS Xlator, this crash was observed. The setup with 48 NFS Clients with 1 NFS Server (Distribute-Replicate) and 4 GlusterFS servers.

(gdb) bt
#0  0x00002aaaab39c215 in raise () from /lib64/libc.so.6
#1  0x00002aaaab39dcc0 in abort () from /lib64/libc.so.6
#2  0x00002aaaab395696 in __assert_fail () from /lib64/libc.so.6
#3  0x00002aaaaacf1cec in __inode_unref (inode=0x2861c90) at inode.c:356
#4  0x00002aaaaacf1dc5 in inode_unref (inode=0x2861c90) at inode.c:395
#5  0x00002aaaaace0dbd in loc_wipe (loc=0x2aaae237cc80) at xlator.c:986
#6  0x00002aaaac15e17c in afr_local_cleanup (local=0x2aaae237cc50, this=0x6163d0) at afr.c:334
#7  0x00002aaaac17532c in afr_unlink_done (frame=0x2aaab3dc6258, this=0x6163d0) at afr-dir-write.c:1723
#8  0x00002aaaac1856f7 in afr_unlock_common_cbk (frame=0x2aaab3dc6258, cookie=0x55fa100, this=0x6163d0, op_ret=0, op_errno=0) at afr-transaction.c:514
#9  0x00002aaaabf49a6a in client_entrylk_cbk (frame=0x55fa100, hdr=0x5bc9400, hdrlen=108, iobuf=0x0) at client-protocol.c:5073
#10 0x00002aaaabf4c55c in protocol_client_interpret (this=0x614330, trans=0x621230, hdr_p=0x5bc9400 "", hdrlen=108, iobuf=0x0) at client-protocol.c:6093
#11 0x00002aaaabf4d222 in protocol_client_pollin (this=0x614330, trans=0x621230) at client-protocol.c:6391
#12 0x00002aaaabf4d899 in notify (this=0x614330, event=2, data=0x621230) at client-protocol.c:6510
#13 0x00002aaaaace0b7c in xlator_notify (xl=0x614330, event=2, data=0x621230) at xlator.c:919
#14 0x00002aaaad49be96 in socket_event_poll_in (this=0x621230) at socket.c:731
#15 0x00002aaaad49c18b in socket_event_handler (fd=14, idx=5, data=0x621230, poll_in=1, poll_out=0, poll_err=0) at socket.c:831
#16 0x00002aaaaad072b9 in event_dispatch_epoll_handler (event_pool=0x60c8b0, events=0x6258c0, i=2) at event.c:804
#17 0x00002aaaaad0748e in event_dispatch_epoll (event_pool=0x60c8b0) at event.c:867
#18 0x00002aaaaad077a4 in event_dispatch (event_pool=0x60c8b0) at event.c:975
#19 0x0000000000406344 in main (argc=8, argv=0x7fff59844b38) at glusterfsd.c:1494
Comment 1 Shehjar Tikoo 2010-05-05 01:22:19 EDT

*** This bug has been marked as a duplicate of bug 857 ***
Comment 2 Shehjar Tikoo 2010-05-14 00:13:22 EDT
Re-opened because 857 turned out to be unrelated to NFS.
Comment 3 Shehjar Tikoo 2010-05-14 00:14:01 EDT

*** This bug has been marked as a duplicate of bug 855 ***

Note You need to log in before you can comment on or make changes to this bug.