Bug 76284 - Installer fails to copy SCSI modules to initial ram disk
Installer fails to copy SCSI modules to initial ram disk
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-19 01:54 EDT by Colin Bloch
Modified: 2007-04-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 10:55:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Bloch 2002-10-19 01:54:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE 6.0; Windows NT 5.1;)

Description of problem:
An upgrade from 7.3 to 8.0 with root partition being standard /dev/sda1
yielded a 'kernel panic, VFS couldn't mount root on 08:01'.  The reason for this
is that for some reason only jbd.o and ext3.o were in /boot/initrd-2.4.18-14.img
- manually copying aic7xxx.o, scsi_mod.o, and sd_mod.o and then modifying
linuxrc on the initrd by adding the following lines fixed it:
echo "Loading scsi_mod module"
insmod /lib/scsi_mod.o
echo "Loading sd_mod module"
insmod /lib/sd_mod.o
echo "Loading aic7xxx module"
insmod /lib/aic7xxx.o
I had to boot off the rescue disk, uncompress the initrd & mount it as a loop
device naturally to do this.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Upgrade SCSI-based system, I would assume.

Additional info:

I can't believe this hasn't been reported.  I did a vanilla upgrade from 7.3 to
8.0 without choosing anything other than the defaults all the way through. 
Naturally since the upgrade is completed, I can't reproduce it however I did do
a re-upgrade and it did not correct the initrd problem.
Comment 1 Jeremy Katz 2002-10-19 14:50:25 EDT
What are the contents of your /etc/modules.conf?
Comment 2 Colin Bloch 2002-10-19 14:52:47 EDT
alias parport_lowlevel parport_pc
alias eth0 eepro100
alias eth1 tulip
alias scsi_hostadapter aic7xxx
alias usb-controller usb-uhci
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
alias char-major-13 input
above input joydev ns558 analog
options analog js=gamepad 
options agpgart agp_try_unsupported=1 
alias sound-slot-0 i810_audio
alias sound-slot-1 i810_audio
alias sound-service-1-0 i810_audio
alias sound-service-0-3 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
alias parport_lowlevel parport_pc
alias char-major-195 NVdriver
Comment 3 Colin Bloch 2002-10-19 15:42:05 EDT
I don't know if this is relevant to the problem, but I get the following bootup
error which does not appear to affect/harm anything:
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
Comment 4 Jeremy Katz 2002-10-21 00:23:40 EDT
That's strange as mkinitrd should be adding the scsi adapter if the module is
listed in /etc/modules.conf --  what output do you get from

/sbin/mkinitrd -v /tmp/initrd 2.4.18-14
Comment 5 Colin Bloch 2002-10-21 09:33:48 EDT
It works properly now:

[root@home stuff]# /sbin/mkinitrd -v /tmp/initrd 2.4.18-17.8.0
Using modules:  ./kernel/drivers/usb/usbcore.o ./kernel/drivers/usb/usb-uhci.o
./kernel/drivers/scsi/scsi_mod.o ./kernel/drivers/scsi/sd_mod.o
./kernel/drivers/usb/storage/usb-storage.o
./kernel/drivers/scsi/aic7xxx/aic7xxx.o ./kernel/fs/jbd/jbd.o
./kernel/fs/ext3/ext3.o
Using loopback device /dev/loop0
/sbin/nash -> /tmp/initrd.UWyGrd/bin/nash
/sbin/insmod.static -> /tmp/initrd.UWyGrd/bin/insmod
`/lib/modules/2.4.18-17.8.0/./kernel/drivers/usb/usbcore.o' ->
`/tmp/initrd.UWyGrd/lib/usbcore.o'
`/lib/modules/2.4.18-17.8.0/./kernel/drivers/usb/usb-uhci.o' ->
`/tmp/initrd.UWyGrd/lib/usb-uhci.o'
`/lib/modules/2.4.18-17.8.0/./kernel/drivers/scsi/scsi_mod.o' ->
`/tmp/initrd.UWyGrd/lib/scsi_mod.o'
`/lib/modules/2.4.18-17.8.0/./kernel/drivers/scsi/sd_mod.o' ->
`/tmp/initrd.UWyGrd/lib/sd_mod.o'
`/lib/modules/2.4.18-17.8.0/./kernel/drivers/usb/storage/usb-storage.o' ->
`/tmp/initrd.UWyGrd/lib/usb-storage.o'
`/lib/modules/2.4.18-17.8.0/./kernel/drivers/scsi/aic7xxx/aic7xxx.o' ->
`/tmp/initrd.UWyGrd/lib/aic7xxx.o'
`/lib/modules/2.4.18-17.8.0/./kernel/fs/jbd/jbd.o' -> `/tmp/initrd.UWyGrd/lib/jbd.o'
`/lib/modules/2.4.18-17.8.0/./kernel/fs/ext3/ext3.o' ->
`/tmp/initrd.UWyGrd/lib/ext3.o'
Loading module usbcore
Loading module usb-uhci
Loading module scsi_mod
Loading module sd_mod
Loading module usb-storage
Loading module aic7xxx
Loading module jbd
Loading module ext3
Comment 6 William M. Koos, Jr. 2002-11-04 18:12:13 EST
I have a very similar issue upgrading from RH 6.2 to 8.0.  The system I am 
upgrading is a VA Linux server FullOn 2240 with an on motherboard adaptec 
AIC7896 SCSI controller using BIOS v2.57S2B3 (used for tape backup) and a PCI 
add-on Mylex AcceleRAID 150 SCSI controller using BIOS 4.10-50 and firmware 
4.08-0-37(used for RAIDed Hard drives).  The install seems to go flawlessly and 
I am able to upgrade the file system to ext3 and it appears to load the aic7xxx 
and DAC960 modules.  The system then reboots, grub comes up (from the hard 
drive), and then it starts to load RH Linux 8.  The following prints to the 
screen:
...
Loading scsi_mod module
SCSI subsystem driver Revision: 1.00
Loading sd_mod module
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
Loading AIC7xxx module
PCI: Assigned IRQ 11 for Device 00:0c.0
PCI: Sharing IRQ 11 with 00:09.1
PCI: Sharing IRQ 11 with 00:0c.1

PCI Assigned IRQ 11 for Device 00:0c.1
PCI: Sharing IRQ 11 with 00:09.1
PCI: Sharing IRQ 11 with 00:0c.0

scsi0: Adaptec 7xxx ...
scsi1: Adaptec 7xxx ...

Then it loops the next part forever with incrementing scsi ids

QINFIFO entries:
Waiting Queue entries:
Disconnected Queue entries:
QOUTFIFO entries:
Sequencer Free SCB List: 0 ... 31
Sequencer SCB Info: 0(c 0x0, s 0x47, l 0, t 0xff) 1(c 0x0, s 0xff, l 255, t 
0xff) ... 31(c 0x0, s 0xff, l 255, t 0xff)
Pending List:
Kernel Free SCB list: 210  or  310
DEVQ(0:3:0): 0 waiting
scsi 0:0:x:0 Command already completed   or   scsi 0:0:x:0 Attempting to queue 
a TARGET RESET message
scsi 0:0:x:0 is not an active device
aic7xxx_abort returns 0x2002  or  aic7xxx_dev_reset returns 0x2002

Due to the failed to exec modprobe error, I believe that the SCSI modules did 
not get built into the initrd image correctly.  I read bug id 76284, but I 
don't follow how /sbin/mkinitrd -v /tmp/initrd 2.4.18-14 can help me before i 
get into linux.  Is the recovery method, initially listed, the only way to 
build the correct initrd image?
Comment 7 Jeremy Katz 2003-01-12 14:57:14 EST
Aha, you have a usb-storage device.  We've added workarounds to prevent them
from causing problems in our current internal trees.
Comment 8 Brent Fox 2003-05-25 10:55:09 EDT
I'm going through Bugzilla closing some bugs that have been marked as Modified
for some period of time.  I believe that most of these issues have been fixed,
so I'm resolving these bugs as Rawhide.  If the bug you are seeing still exists,
please reopen this report and mark it as Reopened.

Note You need to log in before you can comment on or make changes to this bug.