Bug 76316 - Workspace Switcher forgets number workspaces under sawfish
Workspace Switcher forgets number workspaces under sawfish
Status: CLOSED DUPLICATE of bug 75474
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-10-19 16:44 EDT by David Shochat
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-11-05 14:39:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Shochat 2002-10-19 16:44:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021016

Description of problem:
When running the GNOME desktop with sawfish as the WM, I get one 
workspace by default in the Workspace Switcher. I can easily change 
this using Workspace Switcher Preferences to 4, say, but once I log out and then
back in again, it is back to 1. Checking "save current setup" when logging out
does not help. When using metacity, everything 
works properly (the # of worspaces is remembered across logins).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run sawfish window manager under GNOME.
2. Set the number of workspaces to 4 using Workspace Switcher Preferences.
3. Log out
4. Log back in

Actual Results:  Only 1 workspace in the Desktop Switcher applet.

Expected Results:  4 workspaces.

Additional info:
The Workspace Switcher functions properly, once the desired # workspaces has 
been set (again!).
1. Don't use sawfish (metacity doesn't have this problem).
2. Fix the number of workspaces every time you log in (annoying).
Comment 1 Bill Nottingham 2002-11-07 22:51:07 EST

*** This bug has been marked as a duplicate of 75474 ***

Note You need to log in before you can comment on or make changes to this bug.