Bug 763197 - (GLUSTER-1465) export dir fd leak during inode to path resolution
export dir fd leak during inode to path resolution
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
nfs-alpha
All Linux
low Severity medium
: ---
: ---
Assigned To: Shehjar Tikoo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-27 20:55 EDT by Krishna Srinivas
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTP
Mount Type: nfs
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Krishna Srinivas 2010-08-27 20:55:14 EDT
[root@brick1 ~]# ls -l /proc/30418/fd
total 0
lrwx------ 1 root root 64 Aug 26 18:33 0 -> /dev/null
lrwx------ 1 root root 64 Aug 26 18:33 1 -> /dev/null
lrwx------ 1 root root 64 Aug 26 18:33 10 -> /export/export
lrwx------ 1 root root 64 Aug 26 18:33 11 -> /export/export/ubuntu1/ubuntu1-flat.vmdk
lrwx------ 1 root root 64 Aug 26 18:33 12 -> /export/export/ubuntu1/.lck-0c000001b30e0000
lrwx------ 1 root root 64 Aug 26 18:33 13 -> /export/export/ubuntu1/.lck-14000001b30e0000
lrwx------ 1 root root 64 Aug 26 18:33 2 -> /dev/null
lrwx------ 1 root root 64 Aug 26 18:33 3 -> anon_inode:[eventpoll]
l-wx------ 1 root root 64 Aug 26 18:33 4 -> /share/kris/install/var/log/glusterfs/share-kris-volfiles-vmstore-export1.vol.log
lr-x------ 1 root root 64 Aug 26 18:33 5 -> /share/kris/volfiles/vmstore/export1.vol
lrwx------ 1 root root 64 Aug 26 18:33 6 -> socket:[61096]
l-wx------ 1 root root 64 Aug 26 18:33 7 -> pipe:[61092]
lrwx------ 1 root root 64 Aug 26 18:33 8 -> socket:[72015]
lrwx------ 1 root root 64 Aug 26 18:33 9 -> socket:[72018]
[root@brick1 ~]#

lrwx------ 1 root root 64 Aug 26 18:33 10 -> /export/export

indicates that there is still dir fd leak on the export dir. This happens sometimes when nfs server is restarted.
Comment 1 Shehjar Tikoo 2010-08-28 01:52:05 EDT
What changes/happens between the first and second ls? nfs server restart?
Comment 2 Shehjar Tikoo 2010-10-05 04:38:54 EDT
not able to reproduce it. Most certainly fixed as part of the fd leaks fixes for 1397.

Note You need to log in before you can comment on or make changes to this bug.