Bug 76320 - Name server timeout when looking up bl.spamcop.net
Name server timeout when looking up bl.spamcop.net
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-19 18:25 EDT by David Both
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-22 07:25:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Both 2002-10-19 18:25:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Description of problem:
I have just installed Red Hat Linux 8.0 on some of my systems. One of them is a
mail server and the sendmail.mc file contains the lines:

         FEATURE(`blacklist_recipients')dnl
         FEATURE(`dnsbl', `relays.ordb.org', `Rejected - see http://ordb.org/')dnl
         FEATURE(`dnsbl', `bl.spamcop.net', `"Spam blocked see:
http://spamcop.net/bl.shtml?"$&{client_addr}')dnl

I cut and pasted the feature lines from the older version of the sendmail.cf
file and then ran m4. This does not seem to work as it did before because the
spamcop entry generates an error when sendmail attempts to check e-mail against
the spamcop black hole list.

This example is from a system with sendmail-8.11.6-3 installed under Red Hat
Linux 7.2 using the same lines in the sendmail.cf file.

        sendmail -bt -Csendmail.cf
        ADDRESS TEST MODE (ruleset 3 NOT automatically invoked)
        Enter <ruleset> <address>
        > .D{client_addr}216.187.234.146
        > Basic_check_relay <>
        Basic_check_rela   input: < >
        Basic_check_rela returns: OKSOFAR

This is from a Red Hat Linux 8.0 system with sendmail-8.12.5-7 with those same
lines.

        sendmail -bt -Csendmail.cf
        ADDRESS TEST MODE (ruleset 3 NOT automatically invoked)
        Enter <ruleset> <address>
        > .D{client_addr}216.187.234.146
        > Basic_check_relay <>
        Basic_check_rela   input: < >
        146.234.187.216.bl.spamcop.net.: Name server timeout
        Basic_check_rela returns: OKSOFAR
        == Ruleset Basic_check_relay (189) status 75
        > No address!

Note that the address used is irrelevant, the results are the same. The given
address is my own Linux firewall wally.both.org.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. I cut and pasted the feature lines from the older version of the sendmail.cf
file and then ran m4 and copied the resulting output to /etc/sendmail.cf.

2. Restart sendmail

service sendmail restart
Shutting down sendmail:                                    [  OK  ]
Shutting down sm-client:                                   [  OK  ]
Starting sendmail:                                         [  OK  ]
Starting sm-client:                                        [  OK  ]

3. Use sendmail -bt to test. This is from a Red Hat Linux 8.0 system with
sendmail-8.12.5-7

        sendmail -bt -Csendmail.cf
        ADDRESS TEST MODE (ruleset 3 NOT automatically invoked)
        Enter <ruleset> <address>
        > .D{client_addr}216.187.234.146
        > Basic_check_relay <>
        Basic_check_rela   input: < >
        146.234.187.216.bl.spamcop.net.: Name server timeout
        Basic_check_rela returns: OKSOFAR
        == Ruleset Basic_check_relay (189) status 75
        > No address!


Additional info:

I thought this might be that spamcop was offline or that the DNS was having a
problem, but the same feature lines work fine on another system I have with Red
Hat 7.2 and sendmail-8.11.6-3.

The result is that e-mail gets delivered, but some spam gets through that should
not.
Comment 1 Florian La Roche 2003-01-22 07:25:07 EST
bl.spamcop.net is not a valid hostname and I am not sure spamcop is
in production already or still an experimental service.

I would recommend spamassassin for email filtering and spam
blocking.

greetings,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.