Bug 76321 - WIDGET_REALIZED_FOR_EVENT and bonobo leak assertions triggered by nautilus
WIDGET_REALIZED_FOR_EVENT and bonobo leak assertions triggered by nautilus
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Jay Turner
:
: 72610 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-19 18:36 EDT by Need Real Name
Modified: 2015-01-07 19:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 08:51:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-19 18:36:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
Description of Problem:

The following error messages showed up, multiple times, during trial runs

(nautilus:19386): Gtk-CRITICAL **: file gtkwidget.c: line 2933
(gtk_widget_event): assertion `WIDGET_REALIZED_FOR_EVENT (widget, event)' failed

and also

(nautilus:976): Bonobo-WARNING **: Leaked a total of 2 refs to 2 bonobo object(s)
(nautilus:19143): Bonobo-WARNING **: Leaked a total of 1 refs to 1 bonobo object(s)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start Gnome desktop with startx
2.Use Gnome menu tree to logoff
3.Examine /var/log/messages
	

Additional info:

WIDGET_REALIZED_FOR_EVENT errors occur very frequently during operation and
*always* occur when logging off.  Bonobo leaks are frequent, but not as numerous
or reproducible.

Bugs 72610 and 72612 report similar problems in the Public Beta.
Comment 1 Havoc Pennington 2002-11-05 14:04:40 EST
These warnings are harmless, though they should go away of course.
Comment 2 Alexander Larsson 2003-01-16 11:02:39 EST
*** Bug 72610 has been marked as a duplicate of this bug. ***
Comment 3 Alexander Larsson 2004-10-04 08:51:20 EDT
Should be fixed now. Reopen if anyone sees this again.

Note You need to log in before you can comment on or make changes to this bug.