Bug 763240 - (GLUSTER-1508) add-brick works but files are not distributed to newly added server
add-brick works but files are not distributed to newly added server
Status: CLOSED DUPLICATE of bug 763213
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Amar Tumballi
Depends On:
  Show dependency treegraph
Reported: 2010-09-02 03:28 EDT by Lakshmipathi G
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed:
Type: ---
Regression: RTP
Mount Type: fuse
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lakshmipathi G 2010-09-02 01:29:39 EDT
after using "gluster volume rebalance volname start", the files created under new directory goes to new brick.but files created under existing directory goes to old bricks, not to new brick.
Comment 1 Lakshmipathi G 2010-09-02 03:28:35 EDT
using add-brick,I have added new brick to exising 2 dht server.
gluster volume info
Number of Volumes: 1

Volume Name: simpledht
Type: None
Status: Started
Number of Bricks: 3
creating new files from client mount point,
touch {200..20000}
all files  goes to brick1 and brick2,but not to brick3
Comment 2 Lakshmipathi G 2010-09-02 03:52:55 EDT
Now adding 2 servers instead of one,
gluster volume add-brick chk
Add Brick successful

created files - 
# touch F{1..100}

these new files distributed into new bricks without doing rebalance.
Comment 3 Vijay Bellur 2010-09-02 05:56:53 EDT
PATCH: http://patches.gluster.com/patch/4485 in master (cluster/dht: fixes to handle 'fix.layout' attribute properly.)
Comment 4 Vijay Bellur 2010-09-02 06:31:54 EDT
PATCH: http://patches.gluster.com/patch/4488 in master (cluster/distribute: add option 'use-readdirp' to force readdirp)
Comment 5 Vijay Bellur 2010-09-02 06:31:59 EDT
PATCH: http://patches.gluster.com/patch/4489 in master (mgmt/glusterd: fix rebalance with new option use-readdirp)
Comment 6 Lakshmipathi G 2010-09-03 23:50:05 EDT
tested this issue with qa15 - 
added third brick and ran rebalance -

#gluster volume rebalance bug763241 start
starting defrag on volume bug763241 has been successful volume rebalance bug763241 status
rebalance completed: rebalanced 0 files of size 0 (total files scanned 1001)

new brick is empty.

# getfattr -n trusted.glusterfs.pathinfo .
# file: .
trusted.glusterfs.pathinfo="(bug763241-dht-layout (bug763241-client-2 0 0) (bug763241-client-0 0 2147483646) (bug763241-client-1 2147483647 4294967295))\000"

created a new directory "f1"  under mnt-pt:
[root@ip-10-245-210-193 mnt]# getfattr -n trusted.glusterfs.pathinfo f1
# file: f1
trusted.glusterfs.pathinfo="(bug763241-dht-layout (bug763241-client-0 2863311530 4294967295) (bug763241-client-1 0 1431655764) (bug763241-client-2 1431655765 2863311529))\000"
Comment 7 Amar Tumballi 2010-09-07 09:28:18 EDT

*** This bug has been marked as a duplicate of bug 1481 ***
Comment 8 Vijay Bellur 2010-10-18 03:25:44 EDT
PATCH: http://patches.gluster.com/patch/5504 in release-3.0 (cluster/distribute: add option 'use-readdirp' to force readdirp)

Note You need to log in before you can comment on or make changes to this bug.