Bug 763291 - (GLUSTER-1559) rsync hangs over rdma
rsync hangs over rdma
Status: CLOSED DUPLICATE of bug 763263
Product: GlusterFS
Classification: Community
Component: rdma (Show other bugs)
mainline
All Linux
low Severity high
: ---
: ---
Assigned To: Raghavendra G
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-07 08:48 EDT by Anush Shetty
Modified: 2015-12-01 11:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2010-09-07 08:48:29 EDT
Trying to rsync /usr to the mount point. It worked over tcp but was hung over rdma

[2010-09-07 04:42:01.686276] D [afr-lk-common.c:989:afr_lock_blocking] sep7-replicate-0: we're done locking
[2010-09-07 04:42:01.686297] D [afr-transaction.c:887:afr_post_blocking_inodelk_cbk] sep7-replicate-0: Blocking inodelks done. Proceeding to FOP
[2010-09-07 04:42:01.686785] D [afr-lk-common.c:410:transaction_lk_op] sep7-replicate-0: lk op is for a transaction
[2010-09-07 04:42:01.695158] D [afr-transaction.c:912:afr_post_nonblocking_inodelk_cbk] sep7-replicate-0: Non blocking inodelks done. Proceeding to FOP
[2010-09-07 04:42:01.695766] D [afr-lk-common.c:410:transaction_lk_op] sep7-replicate-0: lk op is for a transaction
[2010-09-07 04:42:01.698373] D [afr-transaction.c:912:afr_post_nonblocking_inodelk_cbk] sep7-replicate-0: Non blocking inodelks done. Proceeding to FOP
[2010-09-07 04:42:01.698984] D [afr-lk-common.c:410:transaction_lk_op] sep7-replicate-0: lk op is for a transaction
[2010-09-07 04:42:01.706412] D [afr-lk-common.c:989:afr_lock_blocking] sep7-replicate-0: we're done locking
[2010-09-07 04:42:01.706433] D [afr-transaction.c:983:afr_post_blocking_rename_cbk] sep7-replicate-0: Blocking entrylks done. Proceeding to FOP
[2010-09-07 04:42:01.708102] D [afr-lk-common.c:410:transaction_lk_op] sep7-replicate-0: lk op is for a transaction
[2010-09-07 04:42:01.708120] D [afr-lk-common.c:1637:afr_rename_unlock] sep7-replicate-0: unlocking lower
[2010-09-07 04:42:01.708191] D [afr-lk-common.c:1592:afr_post_unlock_lower_cbk] sep7-replicate-0: unlocking higher
[2010-09-07 05:11:32.133027] E [rpc-clnt.c:196:call_bail] sep7-client-0: bailing out frame type(GlusterFS 3.1) op(ENTRYLK(31)) sent = 2010-09-07 04:41:24. timeout = 1800
[2010-09-07 05:11:32.133225] D [afr-lk-common.c:989:afr_lock_blocking] sep7-replicate-0: we're done locking
[2010-09-07 05:11:32.133410] D [afr-transaction.c:935:afr_post_blocking_entrylk_cbk] sep7-replicate-0: Blocking entrylks done. Proceeding to FOP
[2010-09-07 05:11:32.134860] D [afr-lk-common.c:410:transaction_lk_op] sep7-replicate-0: lk op is for a transaction
[2010-09-07 05:11:32.135468] D [afr-lk-common.c:410:transaction_lk_op] sep7-replicate-0: lk op is for a transaction
[2010-09-07 05:11:32.135488] D [afr-transaction.c:906:afr_post_nonblocking_inodelk_cbk] sep7-replicate-0: Non blocking inodelks failed. Proceeding to blocking
[2010-09-07 05:11:32.135643] D [afr-lk-common.c:410:transaction_lk_op] sep7-replicate-1: lk op is for a transaction
[2010-09-07 05:11:32.135660] D [afr-transaction.c:906:afr_post_nonblocking_inodelk_cbk] sep7-replicate-1: Non blocking inodelks failed. Proceeding to blocking
[2010-09-07 05:11:32.136775] D [afr-lk-common.c:966:afr_lock_blocking] sep7-replicate-0: unable to lock on even one child
[2010-09-07 05:11:32.136792] D [afr-lk-common.c:410:transaction_lk_op] sep7-replicate-0: lk op is for a transaction
[2010-09-07 05:11:32.136805] D [afr-transaction.c:882:afr_post_blocking_inodelk_cbk] sep7-replicate-0: Blocking inodelks failed.
[2010-09-07 05:11:32.136887] D [afr-lk-common.c:966:afr_lock_blocking] sep7-replicate-1: unable to lock on even one child
[2010-09-07 05:11:32.136901] D [afr-lk-common.c:410:transaction_lk_op] sep7-replicate-1: lk op is for a transaction
[2010-09-07 05:11:32.136914] D [afr-transaction.c:882:afr_post_blocking_inodelk_cbk] sep7-replicate-1: Blocking inodelks failed.
[2010-09-07 05:11:32.138873] D [afr-common.c:548:afr_lookup_collect_xattr] sep7-replicate-0: entry self-heal is pending for /usr/share/man.
[2010-09-07 05:11:32.139598] I [afr-common.c:655:afr_lookup_done] sep7-replicate-0: entries are missing in lookup of /usr/share/man/man3p.
[2010-09-07 05:11:32.142892] I [afr-common.c:711:afr_lookup_done] sep7-replicate-0: background  meta-data data entry self-heal triggered. path: /usr/share/man/man3p
Comment 1 Raghavendra G 2010-10-04 23:58:54 EDT

*** This bug has been marked as a duplicate of bug 1531 ***

Note You need to log in before you can comment on or make changes to this bug.