Bug 76333 - Nautilus crash: relocation error: undefined symbol: eel_background_get_sample_size
Nautilus crash: relocation error: undefined symbol: eel_background_get_sample...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: nautilus (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-20 01:59 EDT by Paul M Edwards
Modified: 2015-01-07 19:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-20 02:05:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul M Edwards 2002-10-20 01:59:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I'm running Ximian Gnome (1.4) and updated Nautilus (and Nautilus-Mozilla) to
1.0.6-16 from the Red-Hat channel.
Nothing else was updated.
Now nautilus dies and throws this error to stderr:

nautilus: relocation error: /usr/lib/libnautilus-private.so.0: undefined symbol:
eel_background_get_sample_size

Nothing else was updated and when I revert to Nautilus & Nautilus-Mozilla
1.0.6-15.ximian.14 it works fine again.

I will also post this to bugzilla.ximian.com, but I think the problem is in the
Red Hat package. :(

Version-Release number of selected component (if applicable):
1.0.6-16

How reproducible:
Always

Steps to Reproduce:
1. Install Nautilus 1.0.6-16 from the Red-Hat channel.
2. Kill current nautiuls processes and watch as they flounder trying to reload.
3. Spawn new process from terminal and observe crash/error.

Actual Results:
[paul@Paul paul]$ nautilus
nautilus: relocation error: /usr/lib/libnautilus-private.so.0: undefined symbol:
eel_background_get_sample_size
[paul@Paul paul]$

Expected Results:  No crash, no error.
Comment 1 Paul M Edwards 2002-10-20 02:05:32 EDT
http://bugzilla.ximian.com/show_bug.cgi?id=32553
Comment 2 Havoc Pennington 2002-10-20 02:22:22 EDT
You probably have mismatched eel and nautilus packages. This has never been 
reported on a system with only Red Hat packages. You need to stick to 
all Red Hat packages or all Ximian packages, and to go back and forth you 
need to uninstall _all_ GNOME packages from the other source. See the release notes.

Note You need to log in before you can comment on or make changes to this bug.