Bug 763419 - (GLUSTER-1687) glusterd is still not yet scriptable
glusterd is still not yet scriptable
Status: CLOSED DUPLICATE of bug 763339
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
All Linux
low Severity medium
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-23 15:11 EDT by Csaba Henk
Modified: 2010-09-27 08:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Csaba Henk 2010-09-23 15:11:46 EDT
# cat yow.gluster
peer probe 192.168.2.11
volume create yow 192.168.2.11:/tmp/fx0
# gluster < yow.gluster ; echo "----"; sleep 1; gluster < yow.gluster
Probe successful
Creation of volume yow has been unsuccessful
Host 192.168.2.11 not connected
----
Probe on host 192.168.2.11 port 6969 already a friend
Creation of volume yow has been successful

Somehow this should work out at one go... more synchronization needed somewhere.
Comment 1 Pranith Kumar K 2010-09-27 05:03:14 EDT
pranith @ ~/workspace/1repo
17:30:49 :) $ sudo sh -x cmds1.txt 
+ gluster peer probe 192.168.1.92
Probe successful
+ gluster volume create yow 192.168.1.92:/exports
Creation of volume yow has been successful

With the patch for 1607, it works. The probe event is delayed until the connection is established. So marking it as duplicate for that bug

*** This bug has been marked as a duplicate of bug 1607 ***

Note You need to log in before you can comment on or make changes to this bug.