Bug 763605 - (GLUSTER-1873) Stop volume gluster command execution failed
Stop volume gluster command execution failed
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.1-beta
All Linux
low Severity medium
: ---
: ---
Assigned To: Vijay Bellur
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-08 11:54 EDT by Timothy Asir
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timothy Asir 2010-10-08 11:54:18 EDT
Stop volume gluster command (force) execution failed
when one of the server is down in the storage cloud.


(Note: server2 is down)
[root@server1 Agents]# gluster volume info

Volume Name: songs1
Type: Distribute
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: server1:/data/3a1b93f1-a3b4-462f-b577-c12779724f32/9ca79771-2f95-4364-a9dc-2a62d70bd4ed/exports/brick1
Brick2: server2:/data/19516ffc-9041-443b-a1ce-624c82751946/9ca79771-2f95-4364-a9dc-2a62d70bd4ed/exports/brick1

[root@server1 Agents]# gluster --mode=script volume stop songs1      
Stopping volume songs1 has been unsuccessful

[root@server1 Agents]# gluster --mode=script volume stop songs1 force
Stopping volume songs1 has been unsuccessful


GLUSTER PLATFORM LOG: Utils.log
[2010-10-08 21:16:42.072891] I [Utils.py:167:runCommandBG()]: runCommandBG(): Trying to execute command [gluster --mode=script volume stop songs1 force]
[2010-10-08 21:16:42.122322] I [Utils.py:250:runCommand()]: runCommand(): execution status of command [gluster --mode=script volume stop songs1 force] = [{'Status': 16, 'Stderr': '', 'Stdout': 'Stopping volume songs1 has been unsuccessful\n'}]
Comment 1 Pranith Kumar K 2010-10-13 04:28:59 EDT
Vijay,
      since you said you will fix opinfo lock bug. I am assigning this bug to you. The logs suggest that it failed because of the opinfo lock.

Thanks
Pranith
Comment 2 Anand Avati 2010-10-27 02:57:15 EDT
PATCH: http://patches.gluster.com/patch/5579 in master (mgmt/glusterd: Unlock upon a cli request failure)
Comment 3 Lakshmipathi G 2010-11-19 21:33:52 EST
verified with 3.1.1qa9.
# gluster --mode=script volume stop qa9fun force
Stopping volume qa9fun has been successful

Note You need to log in before you can comment on or make changes to this bug.