This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 763748 - (GLUSTER-2016) "start volume" reports success when volume hasn't actually been started
"start volume" reports success when volume hasn't actually been started
Status: CLOSED DUPLICATE of bug 762935
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
3.1.0
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-26 17:59 EDT by Vikas Gorur
Modified: 2013-12-18 19:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vikas Gorur 2010-10-26 17:59:44 EDT
This happens in many cases - one specific example is:

If the glusterfs-rdma rpm is not installed and the user tries to start a volume of transport type rdma, the "brick" glusterfs processes do not start. Despite this, the CLI reports "volume start has been successful". If you try to mount this volume all accesses simply hang.

The UI should not make false statements. It should only report success when it can verify that all the bricks have started and all the NFS servers have started.
Comment 1 Vijay Bellur 2010-10-28 10:32:30 EDT
This will be addressed when 1203 is fixed.

*** This bug has been marked as a duplicate of bug 1203 ***

Note You need to log in before you can comment on or make changes to this bug.