Bug 763749 - (GLUSTER-2017) Stopping an already stopped volume reports "unsuccessful"
Stopping an already stopped volume reports "unsuccessful"
Status: CLOSED DUPLICATE of bug 763742
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
3.1.0
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-26 18:03 EDT by Vikas Gorur
Modified: 2013-12-18 19:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikas Gorur 2010-10-26 18:03:36 EDT
[root@brick5 ~]# gluster volume stop perf
Stopping volume will make its data inaccessible. Do you want to Continue? (y/n) y
Stopping volume perf has been successful
[root@brick5 ~]# gluster volume stop perf
Stopping volume will make its data inaccessible. Do you want to Continue? (y/n) y
Stopping volume perf has been unsuccessful

The second attempt to stop should simply say, "volume perf already stopped". Since the CLI knows the state of the volume, there is no reason not to check it before trying to stop the volume.
Comment 1 Raghavendra Bhat 2010-10-26 22:42:37 EDT
Vikas, a bug has already been filed for it (2010), and I have sent a patch for it. It says "volume is not in started state" if an attempt is made to stop a volume which is already stopped or just created and has not been started. But 2nd time also it asks for confirmation because the state of a volume is maintained by glusterd and not CLI. Marking this as the duplicate of it.

*** This bug has been marked as a duplicate of bug 2010 ***

Note You need to log in before you can comment on or make changes to this bug.