Bug 763755 (GLUSTER-2023) - add-brick fails in regression
Summary: add-brick fails in regression
Status: CLOSED CURRENTRELEASE
Alias: GLUSTER-2023
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
(Show other bugs)
Version: 3.1.0
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-10-27 10:35 UTC by Pranith Kumar K
Modified: 2010-11-11 06:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anand Avati 2010-10-27 08:13:46 UTC
PATCH: http://patches.gluster.com/patch/5583 in master (mgmt/glusterd: update brick-count as soon as it is added in add-brick)

Comment 1 Pranith Kumar K 2010-10-27 10:35:59 UTC
add-brick fails with the latest git because of the validation done in create_volfiles. The brick count is not updated before the create_volfiles is called.


Note You need to log in before you can comment on or make changes to this bug.