Bug 763799 - (GLUSTER-2067) Mount Glusterfs volume as ftp's datastore, it can't list file
Mount Glusterfs volume as ftp's datastore, it can't list file
Status: CLOSED WORKSFORME
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
3.1.0
All Linux
low Severity low
: ---
: ---
Assigned To: shishir gowda
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-09 03:08 EST by Gluster Fan
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: DNR
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Log (84.48 KB, application/octet-stream)
2010-11-11 18:55 EST, Gluster Fan
no flags Details

  None (edit)
Description Gluster Fan 2010-11-09 03:08:19 EST
Mounted glusterfs's volume as proftp's datastore, the proftp is release 1.3.2a. If I upload a directory by ftp client(such as filezilla) to ftp server, sometimes it could not list files of the directory, the directory look like a empty directory, and can't delete it, then I create new file in this directory, the all files is appear. How to fix this problem?
Comment 1 Vijay Bellur 2010-11-10 22:15:39 EST
Can you please provide the server and nfs log files?
Comment 2 Gluster Fan 2010-11-11 18:55:23 EST
Created attachment 378 [details]
bugfix

Provide nfs and server logs
Comment 3 shishir gowda 2011-01-19 22:35:10 EST
This seems to be an issue with inode management in the older releases which were fixed in latest release.

http://download.gluster.com/pub/gluster/glusterfs/3.1/LATEST/

Please upgrade to latest release and open a bug if you are able to reproduce the error.

Note You need to log in before you can comment on or make changes to this bug.