Bug 763813 - (GLUSTER-2081) gluster CLI does not work over ssh
gluster CLI does not work over ssh
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
3.1.1
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Amar Tumballi
:
: GLUSTER-2004 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-10 16:13 EST by Vikas Gorur
Modified: 2015-12-01 11:45 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTP
Mount Type: ---
Documentation: DNR
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vikas Gorur 2010-11-10 16:13:44 EST
The gluster command cannot be invoked over ssh.

ssh bal-2 '/opt/glusterfs/3.1.1qa5/sbin/gluster peer status'
gf_log_init: failed to open logfile "/dev/stderr" (No such device or address)
failed to open logfile /dev/stderr.  exiting

This makes things difficult for scripting using the gluster CLI.
Comment 1 Anand Avati 2010-11-13 07:02:42 EST
PATCH: http://patches.gluster.com/patch/5674 in master (cli: fix issues with running command over ssh)
Comment 2 shishir gowda 2010-11-14 20:18:15 EST
*** Bug 2004 has been marked as a duplicate of this bug. ***
Comment 3 Amar Tumballi 2010-11-14 23:11:55 EST
Could be seen by having two machines, and trying to run a 'gluster' CLI on remote machine using ssh. Will fail in any version before 3.1.1qa6 with the error given in bug description. With release 3.1.1qa6 onwards it should be fixed.

Adding a regression test case means, adding a gluster cli to run over ssh (preferably passwd-less).
Comment 4 Raghavendra Bhat 2011-02-17 22:07:18 EST
Now gluster command over ssh works.



root@bigbang:/home/raghu# ssh 192.168.1.50 gluster volume info
root@192.168.1.50's password: 

Volume Name: mirror
Type: Replicate
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: 192.168.1.50:/export/mirror
Brick2: 192.168.1.211:/export/mirror
Options Reconfigured:
monitor.xtime-marker: on

Note You need to log in before you can comment on or make changes to this bug.