Bug 763861 - (GLUSTER-2129) [3.1.1qa9]: gluster command line hangs even with glusterd started
[3.1.1qa9]: gluster command line hangs even with glusterd started
Status: CLOSED WONTFIX
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
3.1.1
All Linux
low Severity low
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-18 21:33 EST by Harshavardhana
Modified: 2015-03-22 21:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harshavardhana 2010-11-18 21:33:54 EST
tail -14 /var/log/glusterfs/etc-glusterfs-glusterd.vol.log

[2010-11-19 02:30:12.899015] I [glusterd.c:275:init] management: Using /etc/glusterd as working directory
[2010-11-19 02:30:12.899832] I [glusterd.c:87:glusterd_uuid_init] glusterd: retrieved UUID: 4fc45b6c-64a0-423b-9c05-01cfbef6f73c
Given volfile:
+------------------------------------------------------------------------------+
  1: volume management
  2:     type mgmt/glusterd
  3:     option working-directory /etc/glusterd
  4:     option transport-type socket
  5:     option transport.socket.keepalive-time 10
  6:     option transport.socket.keepalive-interval 2
  7: end-volume
  8: 

+------------------------------------------------------------------------------+


run just "gluster peer status" makes the command hang. Saw this in qa8 upgraded to qa9, same hang. 


strace on gluster command reveals as below 

open("/dev/null", O_WRONLY|O_CREAT|O_APPEND, 0666) = 4
fstat(4, {st_mode=S_IFCHR|0666, st_rdev=makedev(1, 3), ...}) = 0
ioctl(4, SNDCTL_TMR_TIMEBASE or TCGETS, 0x7fffe4b717f0) = -1 ENOTTY (Inappropriate ioctl for device)
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7fd8ce80a000
fstat(4, {st_mode=S_IFCHR|0666, st_rdev=makedev(1, 3), ...}) = 0
lseek(4, 0, SEEK_END)                   = 0
mmap(NULL, 10489856, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS|MAP_STACK, -1, 0) = 0x7fd8c75ff000
mprotect(0x7fd8c75ff000, 4096, PROT_NONE) = 0
clone(child_stack=0x7fd8c7fff210, flags=CLONE_VM|CLONE_FS|CLONE_FILES|CLONE_SIGHAND|CLONE_THREAD|CLONE_SYSVSEM|CLONE_SETTLS|CLONE_PARENT_SETTID|CLONE_CHILD_CLEARTID, parent_tidptr=0x7fd8c7fff9e0, tls=0x7fd8c7fff910, child_tidptr=0x7fd8c7fff9e0) = 8134
futex(0x2175f4c, FUTEX_WAIT_PRIVATE, 1, NULL


Can someone give me inputs on this?. I need to get some testing done quickly. 

Contact me to get the access details to look at the issue.
 
Linux junk5 2.6.30.10-105.2.4.fc11.x86_64 #1 SMP Tue Jan 19 22:46:59 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Harshavardhana 2010-11-21 19:34:28 EST
Figured it out to be a problem with "/etc/hosts" if you don't have 127.0.0.1 as a localhost entry "gluster" command line will hang.  Adding localhost resolves the issue. 

Should we be hanging or can we give a better message? or is it worth the effort since the process was started by gluster command wouldn't run since it has an ip assigned to it.
Comment 2 Pranith Kumar K 2011-01-11 21:20:48 EST
Vijay and I discussed about this bug and decided its not worth fixing so marking it as wontfix.

Note You need to log in before you can comment on or make changes to this bug.