Bug 76387 - Up2date traceback in checkHeaderForFileConfigExcludes
Up2date traceback in checkHeaderForFileConfigExcludes
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.3
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-21 03:54 EDT by Alexander
Modified: 2015-01-07 19:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 18:18:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander 2002-10-21 03:54:38 EDT
Description of Problem:
When i try to use up2date it produces the following error
up2date -u 

Fetching package list for channel: redhat-linux-i386-7.3...
########################################

Fetching Obsoletes list for channel: redhat-linux-i386-7.3...
########################################

Fetching rpm headers...
########################################
Traceback (innermost last):
  File "/usr/sbin/up2date", line 781, in ?
    main()
  File "/usr/sbin/up2date", line 569, in main
    pkgNames, fullUpdate, dryRun = dry_run))
  File "/usr/sbin/up2date", line 724, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 57, in run
    self.__findPackagesToUpdate()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 92, in 
__findPackagesToUpdate
    self.availableUpdates = plist.getPackagesToInstall()
  File "/usr/share/rhn/up2date_client/packageList.py", line 295, in 
getPackagesToInstall
    result = self.__skipPackages(result)
  File "/usr/share/rhn/up2date_client/packageList.py", line 321, in 
__skipPackages
    packageList = self.__skipFiles(packageList)
  File "/usr/share/rhn/up2date_client/packageList.py", line 340, in __skipFiles
    tmp_list = rpmUtils.checkHeaderForFileConfigExcludes(i,packageList[p_i],db)
  File "/usr/share/rhn/up2date_client/rpmUtils.py", line 187, in 
checkHeaderForFileConfigExcludes
    for pattern in cfg.readEntry("fileSkipList"):
TypeError: loop over non-sequence

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. Run up2date -l or up2date -u
2. 
3. 

Actual Results:


Expected Results:
Program would retrieve list of available packages

Additional Information:
I tried to update up2date with the rpm's from the redhat site. And re-register 
the machine again. But this didn't work
Comment 1 Alexander 2002-10-21 04:45:09 EDT
One thing i forgot to mention is that if i use th -f option it all seems to 
work. But i want to exclude a package, so this isn't an option for me.
Comment 2 Adrian Likins 2002-10-23 18:47:40 EDT
has the "fileSkipList" value been removed from the config file?

The error looks like it's getting a "None" value from reading that
config variable, which it shouldn't do if that config variable
exists at all.
Comment 3 Aleksey Nogin 2004-01-15 17:28:25 EST
I am seeing something pretty similar on Fedora Development - see bug
113627

Note You need to log in before you can comment on or make changes to this bug.