Bug 763899 - (GLUSTER-2167) [3.1.1-GA] Spurious File Handle errors for NFS server
[3.1.1-GA] Spurious File Handle errors for NFS server
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
3.1.1
All Linux
low Severity low
: ---
: ---
Assigned To: Shehjar Tikoo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-30 16:44 EST by Harshavardhana
Modified: 2015-03-22 21:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTP
Mount Type: nfs
Documentation: DNR
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harshavardhana 2010-11-30 13:46:29 EST
Unsure what triggered it, but these are coming at odd times and usually occurs when copying data into Gluster with a normal cp or rsync operation. 

Unsure if this is supposed to be error, we should be alarmed or its just a benign message which lingers at wrong log level.
Comment 1 Harshavardhana 2010-11-30 16:44:48 EST
[2010-11-30 20:00:47.360527] E [nfs3.c:675:nfs3_getattr] nfs-nfsv3: Failed to map FH to vol
[2010-11-30 20:00:47.360811] E [nfs3.c:675:nfs3_getattr] nfs-nfsv3: Failed to map FH to vol
[2010-11-30 20:00:47.361083] E [nfs3.c:675:nfs3_getattr] nfs-nfsv3: Failed to map FH to vol
[2010-11-30 20:00:47.361361] E [nfs3.c:675:nfs3_getattr] nfs-nfsv3: Failed to map FH to vol
[2010-11-30 20:00:47.361595] E [nfs3.c:675:nfs3_getattr] nfs-nfsv3: Failed to map FH to vol
[2010-11-30 20:00:47.361864] E [nfs3.c:675:nfs3_getattr] nfs-nfsv3: Failed to map FH to vol
[2010-11-30 20:00:47.362139] E [nfs3.c:675:nfs3_getattr] nfs-nfsv3: Failed to map FH to vol
[2010-11-30 20:00:47.362418] E [nfs3.c:675:nfs3_getattr] nfs-nfsv3: Failed to map FH to vol
[2010-11-30 20:00:47.362692] E [nfs3.c:675:nfs3_getattr] nfs-nfsv3: Failed to map FH to vol
[2010-11-30 20:00:47.362965] E [nfs3.c:675:nfs3_getattr] nfs-nfsv3: Failed to map FH to vol
[2010-11-30 20:00:47.363243] E [nfs3.c:675:nfs3_getattr] nfs-nfsv3: Failed to map FH to vol
Comment 2 Shehjar Tikoo 2010-11-30 21:00:34 EST
Do you see any errors for the apps? Sometimes, the kernel keeps file handles around from previous mounts or mounts that used the same server but a different export.

I've seen these errors for background apps like gnome file monitoring that try to locate a .Trash directory on the mount point.

This is not a problem if your applications are not receiving "Stale file handle".
Comment 3 Shehjar Tikoo 2010-12-17 00:53:00 EST
Harsha, please re-open if the applications are failing because of this error. Thanks.

Note You need to log in before you can comment on or make changes to this bug.