Bug 763978 - (GLUSTER-2246) Handle NFS requestsafter NFS init but before child-up
Handle NFS requestsafter NFS init but before child-up
Status: CLOSED DUPLICATE of bug 763932
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
All Linux
low Severity low
: ---
: ---
Assigned To: Shehjar Tikoo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-22 05:55 EST by Shehjar Tikoo
Modified: 2015-12-01 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTP
Mount Type: nfs
Documentation: DNR
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shehjar Tikoo 2010-12-22 03:03:49 EST

*** This bug has been marked as a duplicate of bug 2200 ***
Comment 1 Shehjar Tikoo 2010-12-22 05:55:04 EST
nfs socket is started before a volume comes up. In that case, there is a window where NFS requests will come in for a volume that is not up and will receive an error. Such requests need to be queue up instead of returning the error or an explicit lookup on root needs to be sent.

Note You need to log in before you can comment on or make changes to this bug.