Bug 764337 - (GLUSTER-2605) NFS:all the directories are not displayed over nfs mount
NFS:all the directories are not displayed over nfs mount
Status: CLOSED DUPLICATE of bug 764365
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Shehjar Tikoo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-29 09:49 EDT by Saurabh
Modified: 2011-03-31 02:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2011-03-29 09:49:45 EDT
[root@centos-qa-client-2 sbin]# ./glusterfs --version
glusterfs 3.2quotaqa4 built on Mar 29 2011 04:55:49
Repository revision: v3.2.1qa2-93-g5fbf25c
Copyright (c) 2006-2010 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU Affero General Public License.



10.1.12.134:/dist1 on /mnt/nfs-test type nfs (rw,nfsvers=3,nolock,addr=10.1.12.134)


[root@centos-qa-client-1 ~]# cd /mnt/nfs-test/
[root@centos-qa-client-1 nfs-test]# ls
test
[root@centos-qa-client-1 nfs-test]# 


But over fuse mount everything is visible,

glusterfs#10.1.12.134:/dist1 on /mnt/gluster-test type fuse (rw,allow_other,default_permissions,max_read=131072)


[root@centos-qa-client-1 ~]# cd /mnt/gluster-test/
[root@centos-qa-client-1 gluster-test]# ls
d1  d2  d3  test
[root@centos-qa-client-1 gluster-test]# 


Problem is only with display, file/directory creation is happening propelry.
Even with display if gives ls for a specific dir/file it gets displayed.

[root@centos-qa-client-1 ~]# cd /mnt/nfs-test/
[root@centos-qa-client-1 nfs-test]# ls
test
[root@centos-qa-client-1 nfs-test]# ls d1
[root@centos-qa-client-1 nfs-test]#
Comment 1 Shehjar Tikoo 2011-03-29 10:09:08 EDT
Was this with the quota release?
Comment 2 Saurabh 2011-03-29 22:12:40 EDT
Yes, this was with quota release
Comment 3 Shehjar Tikoo 2011-03-30 23:09:03 EDT

*** This bug has been marked as a duplicate of bug 2633 ***

Note You need to log in before you can comment on or make changes to this bug.