Bug 76441 - RFE: Ctrl+Alt as alternative to AltGr in XFree86
RFE: Ctrl+Alt as alternative to AltGr in XFree86
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-21 16:57 EDT by Christian Rose
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-21 21:44:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2002-10-21 16:57:58 EDT
In Windows, it's possible to use Ctrl+Alt as an alternative for Alt+Gr when 
composing keys. For example, on the Swedish layout, I can press Ctrl+Alt+2 to 
get an @ instead of having to press AltGr+2. This is an advantage both for 
normally-abled users who can then type this character with one hand, and for 
disabled users who aren't able to use more than one hand efficiently.
Comment 1 Christian Rose 2002-10-21 21:44:48 EDT
Reported upstream to XFree86 now.
Comment 2 Mike A. Harris 2002-10-22 07:30:11 EDT
If upstream makes this change, it'll naturally get included in CVS and
make its way to us eventually.  As with the other keyboard enhancement
RFE's though we won't make the changes here without XFree86 doing so
upstream.

Another issue is that some applications already use these keystroke
bindings for things likely..  but that is something for XFree86.org
to decide, I'm rather neutral personally.

I'm going to close this as WONTFIX for now, because we wont make
the change on our own accord, but if it does get into XFree86 CVS,
then it will end up here in the longrun anyway.  As such, there's
no real need to bugzilla track it per se.

Note You need to log in before you can comment on or make changes to this bug.