Bug 764438 - (GLUSTER-2706) Umount on Mac doesn't work.
Umount on Mac doesn't work.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
3.1.3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Shehjar Tikoo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-10 01:11 EDT by Gaurav
Modified: 2011-04-12 00:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: RTNR
Mount Type: nfs
Documentation: DP
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaurav 2011-04-10 01:11:09 EDT
Mac client sends Getport for Mount1 UDP before sending Umount call, since we don't support UDP it fails, and Mac client doesn't retry for TCP and never send Umount call, in case of Linux it retries with TCP if it fails with UDP, that's ideal behaviour.

Mac client doesn't support mountproto option, as per RFC we can force NFS client to use TCP for MOUNT protocol using mountproto=tcp.

We need to document this behaviour.
Comment 1 Shehjar Tikoo 2011-04-11 21:25:50 EDT
When you'd like something to be documented, set the Documentation flag to "DP"->doc pending. Divya then takes charge of bringing in the documentation. You can help her with the tech details. Turn it into a FAQ question. Ask Divya, she knows how to go about it.

Also, what you described is the protocol level behaviour. You'll need to document the behaviour seen for the Mac command line and Finder UI.

Note You need to log in before you can comment on or make changes to this bug.