Bug 764565 - (GLUSTER-2833) Prevent heterogeneous backend file systems
Prevent heterogeneous backend file systems
Status: CLOSED WONTFIX
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
All All
low Severity low
: ---
: ---
Assigned To: Rajesh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-22 19:33 EDT by Vidya Sakar
Modified: 2013-07-04 18:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 06:21:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2011-04-22 19:33:19 EDT
When a new volume is created and/or when a brick is added to an existing volume, it should make sure that the backend file system type (ext3 | xfs | ext4) is the same in all the bricks.
Comment 1 Anand Avati 2011-04-22 23:38:57 EDT
Why is this a bug? Why should such a check be performed?
Comment 2 Vidya Sakar 2011-04-23 09:19:16 EDT
(In reply to comment #1)
> Why is this a bug? Why should such a check be performed?

We may not have found a bug yet, but there are bound to be differences between file systems even when they are posix compliant. Furthermore, there are performance differences between file systems which will make life difficult for us. Too many variables is not good for predictability / supportability and I do not see a reason for why one would want such a setup.
Comment 3 Vidya Sakar 2011-05-19 07:50:38 EDT
Not sure at what layer the fix is planned, but we need to fix our gluster-provision-* commands too so as to take care of this scenario in our appliances.
Comment 4 Amar Tumballi 2011-09-16 00:23:56 EDT
Lets not prevent it as such, but warn the user while doing 'volume create' about the heterogeneous backend systems.
Comment 5 Amar Tumballi 2011-09-16 00:29:13 EDT
Kaushik already started work on this issue, so he will continue with this.
Comment 6 Amar Tumballi 2011-09-27 01:50:20 EDT
Planing to keep 3.4.x branch as "internal enhancements" release without any features. So moving these bugs to 3.4.0 target milestone.
Comment 7 Shawn Nock 2013-03-05 11:53:55 EST
I've been using heterogeneous bricks; creating new bricks as XFS because of the ext4 problem when using recent kernels.

So far, no issues. Updating the documentation with a recommendation (presumably against) would be helpful.
Comment 8 Rajesh 2013-06-04 06:21:30 EDT
Concluded that this is not to be done as it is not a requirement, and hinders testing of glusterfs. Having homogeneous bricks is not a must.

Note You need to log in before you can comment on or make changes to this bug.