Bug 764566 - (GLUSTER-2834) Prevent heterogeneous GlusterFS versions between bricks
Prevent heterogeneous GlusterFS versions between bricks
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: krishnan parthasarathi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-22 19:37 EDT by Vidya Sakar
Modified: 2015-11-03 18:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-24 01:46:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidya Sakar 2011-04-22 19:37:37 EDT
When a new volume is created and/or when a brick is added to an existing
volume, it should make sure that the GlusterFS version is the same in all the bricks. If this is not the case, it should throw a warning to the user.
Comment 1 Amar Tumballi 2011-09-27 01:49:54 EDT
Planing to keep 3.4.x branch as "internal enhancements" release without any features. So moving these bugs to 3.4.0 target milestone.
Comment 2 krishnan parthasarathi 2012-12-24 01:46:18 EST
With the availability of op-version[1] feature, where all the storage nodes run 'compatible' versions of glusterfs binaries. It is not 'wrong' to have different bricks of a volume having different versions of glusterfs, as long as they are compatible. Closing this as not a bug. 


[1] - http://www.gluster.org/community/documentation/index.php/Features/Opversion

Note You need to log in before you can comment on or make changes to this bug.