Bug 764582 - (GLUSTER-2850) fix/improve log location cli commands
fix/improve log location cli commands
Status: CLOSED WONTFIX
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Venky Shankar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-27 06:29 EDT by Venky Shankar
Modified: 2012-06-08 05:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 05:25:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Venky Shankar 2011-04-27 06:29:26 EDT
Currently the log locate/filename cli commands are broken. We are introducing new commands instead of the old ones (log filename and log locate)

Changes:
1. gluster>volume log set-location <VOLNAME> <DIRECTORY> - to set log directory for a given volume
   gluster>volume log get-location <VOLNAME> - get the current log directory

2. Make it work :)
Comment 1 Vidya Sakar 2011-04-27 07:51:24 EDT
Why are we introducing a new set subcommand? Shouldn't we use the generic volume setting options, something like gluster volume set log location <>. And what about setting log-level? Our get options is not as good as set, but that is a generic problem which is not specific to getting log location.
Comment 2 Venky Shankar 2011-04-27 08:33:10 EDT
(In reply to comment #1)
> Why are we introducing a new set subcommand? Shouldn't we use the generic
> volume setting options, something like gluster volume set log location <>. 

currently the command is "volume log filename" which is misleading as it accepts directory where the log files would be. The command looks like it is accepting the full file path. More importantly it does not work as expected which means no one would be happy by what it does anyway.

> And what about setting log-level? 

We are planning a new command for this: volume log level <VOLUME> <XLATOR> <LOGLEVEL>, which would set the log level for a particular translator (currently we have a global loglevel. We are planning for per-translator log level). I sent a patch for this cli command.

> Our get options is not as good as set, but that is a generic problem which is not specific to getting log location.
Comment 3 Vidya Sakar 2011-04-27 08:48:02 EDT
I think I wasn't clear enough. My question is, why are we proposing this syntax
"# gluster volume log set-location <ARGUMENT>"
instead of
"# gluster volume set log location <ARGUMENT>"
which is how all our other settings are done -
http://www.gluster.com/community/documentation/index.php/Gluster_3.2:_Setting_Volume_Options
Comment 4 Amar Tumballi 2011-04-27 22:25:19 EDT
(In reply to comment #3)
> I think I wasn't clear enough. My question is, why are we proposing this syntax
> "# gluster volume log set-location <ARGUMENT>"
> instead of
> "# gluster volume set log location <ARGUMENT>"
> which is how all our other settings are done -
> http://www.gluster.com/community/documentation/index.php/Gluster_3.2:_Setting_Volume_Options

VS,

We thought it as a activity to fix the issues with already existing 'log' subcommand (there are already 'volume log filename', 'volume log rotate' and 'volume log locate').

We can make 'set-location' as part of volume set subcommand. That should not be a big issue.
Comment 5 Venky Shankar 2011-06-10 03:17:33 EDT
patch sent for this bug: http://patches.gluster.com/patch/7455/
Comment 6 Amar Tumballi 2011-09-27 01:49:54 EDT
Planing to keep 3.4.x branch as "internal enhancements" release without any features. So moving these bugs to 3.4.0 target milestone.
Comment 7 Amar Tumballi 2012-06-08 05:25:28 EDT
gluster log locate and gluster log filename commands are deprecated from 3.3.0 releases.

Note You need to log in before you can comment on or make changes to this bug.