Bug 764638 - (GLUSTER-2906) [FEAT] peer status should show all servers including current server
[FEAT] peer status should show all servers including current server
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
mainline
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Niels de Vos
: FutureFeature, Patch
: 768749 (view as bug list)
Depends On:
Blocks: 870940
  Show dependency treegraph
 
Reported: 2011-05-16 13:28 EDT by Jacob Shucart
Modified: 2013-07-24 13:19 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:19:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jacob Shucart 2011-05-16 13:28:16 EDT
When I run Gluster peer status, it doesn't show the server I'm running the command on.  Please add this.  All Gluster nodes should show the same servers on peer status.
Comment 1 Vijay Bellur 2011-05-17 00:18:33 EDT
peer status is intended to display information about peers. Since the local server is not a peer to itself, I don't see why it should be listed in peer status. Do you want an alternate command which describes the trusted storage pool?
Comment 2 Jacob Shucart 2011-05-17 08:11:46 EDT
Yes, we need a command that describes that.
Comment 3 Amar Tumballi 2011-05-23 04:59:15 EDT
Any priority on this? Also, what should be the new cli? 

I think of 

"bash# gluster cloud info" or "bash# gluster pool info" as the new cli and it just prints one peer (and also local) info per line.. 

bash# gluster pool info
SERVER       UUID      STATUS
server1      <uuid1>   Online
server2      <uuid2>   Offline
server3      <uuid3>   Online
server4      <uuid4>   <Some-other-status-if-any>
Comment 4 Vijay Bellur 2011-05-23 05:03:57 EDT
(In reply to comment #3)
> Any priority on this? Also, what should be the new cli? 
> 
> I think of 
> 
> "bash# gluster cloud info" or "bash# gluster pool info" as the new cli and it
> just prints one peer (and also local) info per line.. 
> 
> bash# gluster pool info
> SERVER       UUID      STATUS
> server1      <uuid1>   Online
> server2      <uuid2>   Offline
> server3      <uuid3>   Online
> server4      <uuid4>   <Some-other-status-if-any>

Dave,

Can you please comment on how we would want this command to be structured?

Thanks,
Vijay
Comment 5 Jacob Shucart 2011-05-23 09:07:24 EDT
since you can't actually create a volume using "localhost", I think even the localhost system should be considered a peer.  My preference would be to just add the local address to peer status and not cretae a whole new command.
Comment 6 Amar Tumballi 2011-09-27 01:49:56 EDT
Planing to keep 3.4.x branch as "internal enhancements" release without any features. So moving these bugs to 3.4.0 target milestone.
Comment 7 Amar Tumballi 2011-12-19 01:16:57 EST
*** Bug 768749 has been marked as a duplicate of this bug. ***
Comment 8 Amar Tumballi 2012-05-18 03:31:36 EDT
We are thinking 'gluster cluster list' as the command which does script friendly, one line output with 'UUID' of glusterd process being the first column.
Comment 9 Shireesh 2012-11-21 08:25:36 EST
*** Bug 870940 has been marked as a duplicate of this bug. ***
Comment 10 Amar Tumballi 2012-11-21 09:23:58 EST
 http://review.gluster.org/4221
Comment 11 Anand Avati 2013-04-20 10:57:13 EDT
REVIEW: http://review.gluster.org/4862 (cli: add a command 'gluster pool list-nodes [--xml]') posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)
Comment 12 Anand Avati 2013-04-22 09:58:12 EDT
REVIEW: http://review.gluster.org/4862 (cli: add a command 'gluster pool list [--xml]') posted (#2) for review on master by Niels de Vos (ndevos@redhat.com)
Comment 13 Anand Avati 2013-04-24 07:31:15 EDT
REVIEW: http://review.gluster.org/4862 (cli: add a command 'gluster pool list [--xml]') posted (#3) for review on master by Niels de Vos (ndevos@redhat.com)
Comment 14 Anand Avati 2013-04-26 07:28:36 EDT
COMMIT: http://review.gluster.org/4862 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit e6b6d1235daa483384d2b0701561b8f3a85be583
Author: Niels de Vos <ndevos@redhat.com>
Date:   Sat Apr 20 16:55:15 2013 +0200

    cli: add a command 'gluster pool list [--xml]'
    
    * unlike 'gluster peer status', which lists only info about peers,
      this command lists localhost also in the list, so the sorted
      output from all the nodes should match.
    
    * made the output script friendly by keeping it one output per line.
    
    Change-Id: I853656753b35c617debbcceecbb71c8d6dd3c334
    BUG: 764638
    Original-review: http://review.gluster.org/4221
    Original-author: Amar Tumballi <amarts@redhat.com>
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/4862
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Note You need to log in before you can comment on or make changes to this bug.