Bug 764701 - (GLUSTER-2969) add --pidfile option
add --pidfile option
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Lakshmipathi G
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-31 17:45 EDT by Joe Julian
Modified: 2011-06-17 11:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Julian 2011-05-31 17:45:04 EDT
Your init script has the unwelcome side effect of killing client mounts due to the fact that it's trying to kill it's nfs child. Blanket killall statements are not the best way to handle this anyway.

Have glusterd take a --pidfile option/an option in glusterd.vol to write it's own pid, as well as the child pid's, to a specified file as those children are spawned. Remove the pids from that file as children are killed (for instance when a volume is stopped).
Comment 1 Anand Avati 2011-06-08 11:17:33 EDT
PATCH: http://patches.gluster.com/patch/7395 in master (build : use pid file to kill nfs process)
Comment 2 Anand Avati 2011-06-08 11:19:32 EDT
PATCH: http://patches.gluster.com/patch/7396 in release-3.2 (build : use pid file to kill nfs process)
Comment 3 Lakshmipathi G 2011-06-10 03:38:09 EDT
installed 3.2.1qa4 and mounted client processes ,then did /etc/init.d/glusterd stop - kills only the glusterd and nfs process and client process is still alive.
Comment 4 Anand Avati 2011-06-17 08:34:20 EDT
PATCH: http://patches.gluster.com/patch/7541 in release-3.1 (build : use pid file to kill nfs process)

Note You need to log in before you can comment on or make changes to this bug.