Bug 764709 - (GLUSTER-2977) Gluster command to view the default values of volume options?
Gluster command to view the default values of volume options?
Status: CLOSED DUPLICATE of bug 763773
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
3.1.3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-02 04:44 EDT by Prasanth
Modified: 2013-12-18 19:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Amar Tumballi 2011-06-02 04:06:44 EDT
Currently there are no CLI command for this. Will think of getting it out.
Comment 1 Prasanth 2011-06-02 04:08:34 EDT
Thanks Amar!
Comment 2 kaushik 2011-06-02 04:09:54 EDT

*** This bug has been marked as a duplicate of bug 2041 ***
Comment 3 Prasanth 2011-06-02 04:25:14 EDT
Since my first request is a different once, I'm opening a separate bug for that (2980).
Comment 4 Prasanth 2011-06-02 04:44:25 EDT
Hello,

I would like to get some idea on the following queries:

1.) Is there any gluster command currently available to reset a particular volume option to its default value? I know that there is "gluster volume reset" to reset the options completely. But that will reset everything including the other required options as well. So just wanted to know if there is an option to remove/disable a specific option so that it won't list in the next "gluster volume info" output (similar to on/off in translators). If no option is available, please take this as a feature request.


2.) Is there any option/command to view the default values of any volume options? For example: How will I know the default values of "performance.cache-max-file-size" or "performance.cache-min-file-size" without looking at the code or generating a GlusterFS state dump? 

We should be able to view the default values either by executing a command or looking at the volume files (once an option is set, its default value should be given just above/below to it as commented so that we can set to it, if needed, without doing a volume reset). If no option is present, please include this also as a feature request.

Thanks in advance.

Regards,
Prasanth

Note You need to log in before you can comment on or make changes to this bug.