Bug 76482 - lpadmin doesn't recognize gzipped PPD files nicely
lpadmin doesn't recognize gzipped PPD files nicely
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-22 05:55 EDT by Robert P. J. Day
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:18:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert P. J. Day 2002-10-22 05:55:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
  when creating a new printer with "lpadmin -p", one of
the options is -m, which allows you to specify a model
PPD script file to associate with that printer.  this 
PPD file's name must be relative to /usr/share/cups/model.

  however, all of those files are actually gzipped files,
so they all end with a .gz suffix.  if you forget to put the
.gz suffix at the end of the file name, the command will
still create a new printer, but will not copy the model
file into the /etc/cups/ppd directory since, technically,
you didn't get the name correct.

  perhaps lpadmin can be made a bit more forgiving and
assume the existence of the .gz suffix if it's not 
actually given.  or, at the very least, give an error
message that no such file could be found.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.lpadmin -p test (other options) -m laserjet.ppd
2.
3.
	

Actual Results:    no PPD file is associated with the new printer, because
the file is actually laserjet.ppd.gz.

Expected Results:    either figure out that it's the .gz file and use it, 
or generate an error message that no such file existed.
one or the other would be fine, but failing silently is
not a good choice.

Additional info:
Comment 1 Robert P. J. Day 2002-10-22 15:13:01 EDT
  as an addendum, the online browser-based CUPS admin manual, Chapter 3,
under "Adding Your First Printer", shows some examples with
"-m deskjet.ppd" and "-m laserjet.ppd" which, as i just verified
so as not to look foolish, don't work.  adding the .gz to the file name
made it work properly, though.

  so, one way or the other, the command should be brought into sync
with the docs.
Comment 2 Michael Sweet 2003-04-18 10:36:18 EDT
Note: the standard CUPS distribution does not GZIP the sample driver PPD files...
Comment 3 Bill Nottingham 2006-08-07 15:58:04 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 4 Bill Nottingham 2006-10-18 13:18:20 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.