Bug 764919 - (GLUSTER-3187) geo-replication fails if glusterfs installed from src and glusterd started using /etc/init.d/glusterd
geo-replication fails if glusterfs installed from src and glusterd started us...
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
3.2.1
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Csaba Henk
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-18 07:39 EDT by Lakshmipathi G
Modified: 2013-03-05 05:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-05 05:10:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lakshmipathi G 2011-07-18 07:39:59 EDT
Steps to reproduce this issue-
1.Install glusterfs from src. glusterfs installed on default path -

# whereis glusterfs glusterfsd
glusterfs: /usr/local/sbin/glusterfs /usr/local/etc/glusterfs /usr/local/lib/glusterfs
glusterfsd: /usr/local/sbin/glusterfsd

2.start glusterd as "/etc/init.d/glusterd start"
3.Now start geo-replication session - 
It will fail with message like 
"[2011-07-18 02:38:09.618092] E [syncdutils:131:exception] <top>: FAIL: 
Traceback (most recent call last):
  File "/usr/local/libexec/glusterfs/python/syncdaemon/gsyncd.py", line 102, in main
    main_i()
  File "/usr/local/libexec/glusterfs/python/syncdaemon/gsyncd.py", line 296, in main_i
    local.connect()
  File "/usr/local/libexec/glusterfs/python/syncdaemon/resource.py", line 378, in connect
    raise RuntimeError("command failed: " + " ".join(argv))
RuntimeError: command failed: glusterfs -l /usr/local/var/log/glusterfs/geo-replication/geotest/ssh%3A%2F%2Froot%4010.1.12.173%3Afile%3A%2F%2F%2Fexport%2FgeoS.gluster.log -s localhost --volfile-id geotest --client-pid=-1 /tmp/gsyncd-aux-mount-YrZMWu"


It fails because environmental variable PATH invoked from with /etc/init.d/glusterd shows values "PATH=/sbin:/usr/sbin:/bin:/usr/bin"

But installing from src,does not create symlink at /usr/sbin but installs under path /usr/loca/sbin - 

[with rpm installation there is a  sym.link on /usr/sbin/glusterfs to /opt/glusterfs/version/sbin/glusterfs - so there is no issue when its started using /etc/init.d/glusterd]
Comment 1 Venky Shankar 2013-03-05 05:10:19 EST
src and rpms are exclusive now...

Note You need to log in before you can comment on or make changes to this bug.