Bug 765090 - (GLUSTER-3358) If any operation is happening on a volume, stop/delete volume should not be allowed
If any operation is happening on a volume, stop/delete volume should not be a...
Status: CLOSED UPSTREAM
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Amar Tumballi
: Reopened
: GLUSTER-3638 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-08 04:48 EDT by Amar Tumballi
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-18 05:50:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amar Tumballi 2011-08-08 04:48:16 EDT
like, if rebalance is happening on a volume, we should not allow 'volume stop' to proceed. User should be informed of these operations being in progress. 'stop' should be allowed if 'force' option is given along with it.
Comment 1 Amar Tumballi 2011-09-27 10:21:22 EDT
*** Bug 3638 has been marked as a duplicate of this bug. ***
Comment 2 Amar Tumballi 2011-09-29 22:14:13 EDT
patch reviewed and committed from on http://review.gluster.com/518
Comment 3 shylesh 2011-10-18 23:28:27 EDT
This is reproducible on 3.2.5.qa1 so reopening the bug.
Comment 4 Amar Tumballi 2012-02-18 05:50:52 EST
not planing to fix it in 3.2.x branch for now.

Note You need to log in before you can comment on or make changes to this bug.