Bug 765164 - (GLUSTER-3432) glusterd peer probe always results in peer connected (rejected).
glusterd peer probe always results in peer connected (rejected).
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
3.1.5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: krishnan parthasarathi
:
: 765157 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-17 11:01 EDT by krishnan parthasarathi
Modified: 2015-12-01 11:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: 3.2.3
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description krishnan parthasarathi 2011-08-17 11:01:49 EDT
To recreate the problem,

In peer1:
Perform the following:

gluster volume create <volname> <brick1>
gluster volume add <volname> <brick2>
gluster peer probe peer2
gluster peer status

The peer list has peer2 in connected (rejected) state. This
makes it impossible for using peer2 in any volume operation.
Comment 1 Anand Avati 2011-08-20 04:29:30 EDT
CHANGE: http://review.gluster.com/264 (Change-Id: Ia2d89fd919b077232a37debc2aebe1bc72150856) merged in release-3.2 by Vijay Bellur (vijay@gluster.com)
Comment 2 Anand Avati 2011-08-21 04:43:03 EDT
CHANGE: http://review.gluster.com/285 (Change-Id: Ia2d89fd919b077232a37debc2aebe1bc72150856) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 3 Anand Avati 2011-08-24 07:54:03 EDT
CHANGE: http://review.gluster.com/258 (Change-Id: Iec33deaff338a6b48e5015785711de3c8bc9fb2e) merged in release-3.1 by Vijay Bellur (vijay@gluster.com)
Comment 4 Rahul C S 2011-09-05 03:21:13 EDT
Works fine on 3.2.3. On 3.1.7 verification pending on lakshmipathi for a patch for glusterfs.spec file for rpm creation
Comment 5 krishnan parthasarathi 2011-09-06 22:10:19 EDT
*** Bug 3425 has been marked as a duplicate of this bug. ***
Comment 6 Anand Avati 2011-09-07 01:30:01 EDT
CHANGE: http://review.gluster.com/351 (Change-Id: Ib0045149fcdfcfb801b2f1f0a10417b04e294fef) merged in release-3.1 by Vijay Bellur (vijay@gluster.com)
Comment 7 Anand Avati 2011-09-07 06:48:55 EDT
CHANGE: http://review.gluster.com/365 (Change-Id: I3e71461c5a8c5b0d24006f24ad762bb4689ac341) merged in release-3.1 by Vijay Bellur (vijay@gluster.com)

Note You need to log in before you can comment on or make changes to this bug.