Bug 765224 - (GLUSTER-3492) .x (XDR definitions) files are missing for nfs protocol
.x (XDR definitions) files are missing for nfs protocol
Status: CLOSED WONTFIX
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-30 00:37 EDT by Amar Tumballi
Modified: 2013-12-18 19:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Amar Tumballi 2011-08-30 00:37:39 EDT
in 'rpc/xdr/src/' we can just see .[ch] files for nfs protocol structure definitions, but not .x file. Please add the .x file for NFS protocol as that will be the source for generating .[ch] files (bug 765220)
Comment 1 Amar Tumballi 2011-09-07 11:11:01 EDT
Please keep it open. It would still be ideal to keep .x files of NFS protocol also even though protocol is matured and there are no changes which would go into the xdr structures. We do need x files, but as a lesser priority.
Comment 2 Shehjar Tikoo 2011-09-09 03:23:25 EDT
The second point of my email still remains, that the original files are no use because the original generated code is not used directly. It was modified to work with iobufs. I just dont see any use of the original files.
Comment 3 Amar Tumballi 2011-09-21 23:58:03 EDT
Currently no need for it (ref: comment #2)

Note You need to log in before you can comment on or make changes to this bug.