Bug 765307 - (GLUSTER-3575) Replace-brick is not happening properly
Replace-brick is not happening properly
Status: CLOSED DUPLICATE of bug 765289
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: krishnan parthasarathi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-16 09:28 EDT by Vijaykumar
Modified: 2015-12-01 11:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar 2011-09-16 09:28:16 EDT
When you do replace-brick , it is migrating only top level entries , not the data.

Volume Name: dht
Type: Distribute
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: openstack2:/home/gluster/bricks/dht/d3
Brick2: openstack2:/home/gluster/bricks/dht/d2
Comment 1 krishnan parthasarathi 2011-09-17 04:20:49 EDT
Vijaykumar,

What do you mean when you say top level entries? Can you clarify if the directory
tree structure is the same in both source and destination brick after replace-brick operation completes?
Comment 2 Vijaykumar 2011-09-18 22:13:54 EDT
I mean by top level entries is, only first level of directories are copied not the sub directories.
Comment 3 Vijaykumar 2011-09-18 23:04:32 EDT
Its happening in 3.3.0qa9 also.
Comment 4 Vijaykumar 2011-09-18 23:52:58 EDT
Since i can't proceed with some of the other test cases, i am moving it to critical.
Comment 5 krishnan parthasarathi 2011-10-13 04:54:42 EDT

*** This bug has been marked as a duplicate of bug 3557 ***

Note You need to log in before you can comment on or make changes to this bug.