Bug 765377 - (GLUSTER-3645) volume create errors out with mesg " one of the arguments contain the other"
volume create errors out with mesg " one of the arguments contain the other"
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
3.3-beta
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Rajesh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-27 03:57 EDT by Lakshmipathi G
Modified: 2015-12-01 11:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amar Tumballi 2011-09-27 03:12:19 EDT
The issue seems to be result of the below commit.

-----
commit 8ad4d3f53000724389db6003ca6d6d777b880017
Author: Rajesh Amaravathi <rajesh.amaravathi@gmail.com>
Date:   Mon Sep 19 16:43:50 2011 +0530

    glusterd/top: volume top succeeds on partial brickpath

-----

Rajesh, please have a look on it with priority.
Comment 1 Lakshmipathi G 2011-09-27 03:57:23 EDT
with 3.3.qa10 volume create fails  as -

-----
# gluster volume create test 10.1.11.141:/test 10.1.11.141:/test2
Brick: 10.1.11.141:/test, 10.1.11.141:/test2 one of the arguments contain the other
-----
Comment 2 Anand Avati 2011-09-29 09:16:16 EDT
CHANGE: http://review.gluster.com/511 (Earlier, using two directories with names like /test and /test1) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 3 Anand Avati 2011-10-28 05:02:23 EDT
CHANGE: http://review.gluster.com/544 (Earlier, using two directories with names like /test and /test1) merged in master by Vijay Bellur (vijay@gluster.com)

Note You need to log in before you can comment on or make changes to this bug.