This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 765385 - (GLUSTER-3653) Replace-brick status clears off when replace-brick commit fails.
Replace-brick status clears off when replace-brick commit fails.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
pre-release
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: krishnan parthasarathi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-28 04:52 EDT by Vijaykumar
Modified: 2015-11-03 18:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar 2011-09-28 04:52:26 EDT
root@ubuntu10-3:~# gluster volume quota doa list
        path              limit_set          size
----------------------------------------------------------------------------------
/                           1GB             1000.6MB
root@ubuntu10-3:~# gluster volume quota doa list
        path              limit_set          size
----------------------------------------------------------------------------------
/                           1GB             1000.6MB
root@ubuntu10-3:~# gluster volume replace-brick doa 10.1.11.237:/root/bricks/doa/d2 10.1.11.237:/root/bricks/doa/d4 start
replace-brick started successfully
root@ubuntu10-3:~# gluster volume replace-brick doa 10.1.11.237:/root/bricks/doa/d2 10.1.11.237:/root/bricks/doa/d4 status
Number of files migrated = 18       Current file= /2/3/4/5/file24
root@ubuntu10-3:~# gluster volume replace-brick doa 10.1.11.237:/root/bricks/doa/d2 10.1.11.237:/root/bricks/doa/d4 status
Number of files migrated = 18       Current file= /2/3/4/5/file24
root@ubuntu10-3:~# gluster volume replace-brick doa 10.1.11.237:/root/bricks/doa/d2 10.1.11.237:/root/bricks/doa/d4 commit
replace-brick commit failed
root@ubuntu10-3:~# gluster volume replace-brick doa 10.1.11.237:/root/bricks/doa/d2 10.1.11.237:/root/bricks/doa/d4 status
Number of files migrated = 0       Current file=
root@ubuntu10-3:~# gluster volume replace-brick doa 10.1.11.237:/root/bricks/doa/d2 10.1.11.237:/root/bricks/doa/d4 status
Number of files migrated = 1       Current file= /2/3/4/5/file25
root@ubuntu10-3:~# gluster volume replace-brick doa 10.1.11.237:/root/bricks/doa/d2 10.1.11.237:/root/bricks/doa/d4 status
Number of files migrated = 1       Current file= /2/3/4/5/file25
root@ubuntu10-3:~# gluster volume replace-brick doa 10.1.11.237:/root/bricks/doa/d2 10.1.11.237:/root/bricks/doa/d4 status
Number of files migrated = 2       Current file= /2/3/4/5/file10
root@ubuntu10-3:~# gluster volume replace-brick doa 10.1.11.237:/root/bricks/doa/d2 10.1.11.237:/root/bricks/doa/d4 status
Number of files migrated = 4       Current file= /2/3/4/5/6/file5
root@ubuntu10-3:~# gluster volume replace-brick doa 10.1.11.237:/root/bricks/doa/d2 10.1.11.237:/root/bricks/doa/d4 status
Number of files migrated = 8       Current file= /2/3/4/5/6/7/file1
root@ubuntu10-3:~# gluster volume replace-brick doa 10.1.11.237:/root/bricks/doa/d2 10.1.11.237:/root/bricks/doa/d4 status
root@ubuntu10-3:~# gluster volume replace-brick doa 10.1.11.237:/root/bricks/doa/d2 10.1.11.237:/root/bricks/doa/d4 status
root@ubuntu10-3:~# gluster volume replace-brick doa 10.1.11.237:/root/bricks/doa/d2 10.1.11.237:/root/bricks/doa/d4 commit
root@ubuntu10-3:~# gluster volume info
Comment 1 Anand Avati 2011-10-19 03:20:22 EDT
CHANGE: http://review.gluster.com/585 (Clearing pump status on migration complete is futile because we would be) merged in master by Vijay Bellur (vijay@gluster.com)

Note You need to log in before you can comment on or make changes to this bug.