Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 76542 - Installer kernel hangs on boot
Installer kernel hangs on boot
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-22 23:38 EDT by Henry Burroughs
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 09:35:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
redhat 8.0 cd 1 rebuild script (7.81 KB, text/plain)
2002-11-01 13:35 EST, Henry Burroughs
no flags Details

  None (edit)
Description Henry Burroughs 2002-10-22 23:38:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
When I boot the install cd the kernel hangs at this message:
enabled ExtINT on CPU #0
ESR value before enabling vector: 00000002
I have to reset the system; (ctrl-alt-delete) does not work

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot install cd
2. kernel hangs

Actual Results:  The kernel hangs at the above error message

Expected Results:  The kernel to finish loading

Additional info:

My system is an AMD Athlon XP 1600+ (1.4 Ghz) running on a PC CHIPS
(www.pcwave.com) M825 board (via KM266 Northbridge & VT8233 Southbridge)
Matrox G400 Max, Adaptec 2940U2W SCSI card

Redhat 7.3 installs/boots properly
Comment 1 Henry Burroughs 2002-10-22 23:42:17 EDT
Whoops, I forgot to mention that I tried the 'linux noapic' , with no change in
results.
Comment 2 Need Real Name 2002-10-24 17:04:13 EDT
Exact same problem on a PCChips M825LMR MBoard w/ Duron 13.Ghz, have tried 
following kernel parameters: noapic apm=off pci=noacpi mem=nopentium as well as 
all those mentioned on the install screen, none had any effect changing bios  
did nothing also. NB. RH7.3 works fine
I guess we got ripped buying PCChips
Comment 3 Henry Burroughs 2002-10-25 13:51:24 EDT
The problem is with "Local APIC support on uniprocessors" option under
"Processor type and features".  It is enabled on the 2.4.18-14BOOT kernel.  The
regular 2.4.18-14 kernel RPMS will install and boot on a 7.3 system. I've been
attempting to build a new bootdisk (or cdrom), and I am having limited success.
 So basically, we need a new boot.img with the Local APIC options turned off. =)
  My disk might actually work for you (I can get into the installer, but hit an
anaconda bug... it's not loading the ext3,lvm-mod, etc modules so I can't
partition) if you don't have an adaptec SCSI card that uses the aic7xxx
driver.... I think I have found info for another bug (either existing or new),
and I'm not ready to post for it yet...

FMI: I'm using the kernel-2.4.18-14BOOT.rpm and using the website:
http://www.reptechnic.com.au/kickstart.html to pull apart and build a new disk.
Oh, and the kernel-***BOOT.config file in ./config under the 2.4.18-14 kernel
source directory.... and "make oldconfig" i copy the boot config file .config
and run "make oldconfig"
Comment 4 John Hall 2002-10-28 10:40:43 EST
I am having the same problem on an ECS K7VMM (KM266 NB and VT8233 SB) with an
Athlon XP 1800+.  I have tried installing with 'linux noapic' but it still hangs
after displaying the message "ESR value before enabling vector: 00000002". 
RH7.3 installs fine, though.
Comment 5 Henry Burroughs 2002-10-28 12:57:57 EST
Great news!! I am now running RedHat 8.0!  I have built a script to build a new
redhat 8.0 cd 1 (it automates the recompiling of the kernel, rebuilding the
image files, and making a new .iso).  I am currently cleaning it up and fixing a
few things, but otherwise it works great!!!!  I hope to have that posted within
a few days.  So a workaround now exists.
Comment 6 Henry Burroughs 2002-11-01 13:35:26 EST
Created attachment 83064 [details]
redhat 8.0 cd 1 rebuild script
Comment 7 Henry Burroughs 2002-11-01 13:41:59 EST
To clarify what RPMS are necessary (using rh 7.3 as a base) from the 8.0 cd:

kernel-source-2.4.18-14.i386.rpm  (cd 1)
glibc-devel-2.2.93-5.i386.rpm (cd 2)
glibc-2.2.93-5.i686.rpm (cd 2)
glibc-common-2.2.93-5.i386.rpm (cd 2)


just run "rpm -Uvh ...." where .... is all the above kernel/glibc files (you may
want to copy them all to /tmp so you can install them at once and solve the
dependencies)

Thanks jhall!

If you have any problems, let me know.
Comment 8 John Hall 2002-11-02 22:18:55 EST
I can confirm that the script from burrouhb does build a working install CD that
successfully installs Red Hat Linux 8.0 on my ECS K7VMM system.  I am now
running Red Hat Linux 8.0.

Thanks burrouhb!
Comment 9 Need Real Name 2002-11-03 22:30:17 EST
I should have written to this bug report sooner but regardless the bug is 
solved on my machine as well, thanks to burrouhb@acm.org's script.
Thanks to him I think this bug is now closed.
Comment 10 Alan Cox 2003-06-05 09:35:38 EDT
For RH9 we switched off the local apic support due to these sort of problems

Note You need to log in before you can comment on or make changes to this bug.