Bug 765425 - (GLUSTER-3693) Creation of volume fails with the message "Failed to store the Volume information" but actually volume is created
Creation of volume fails with the message "Failed to store the Volume informa...
Status: CLOSED DUPLICATE of bug 765434
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
pre-release
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: krishnan parthasarathi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-05 01:04 EDT by shylesh
Modified: 2015-11-03 18:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shylesh 2011-10-05 01:04:16 EDT
1. I tried to create a replicate volume but it fails with the message "Failed to store the Volume information" 
2. volume info followed by above operation shows the newly created volume\


glusterd logs:-
--------------
[2011-10-05 15:54:27.642777] I [glusterd-handler.c:831:glusterd_handle_cli_get_volume] 0-glusterd: Received get vol req
[2011-10-05 15:54:27.760348] I [glusterd-handler.c:831:glusterd_handle_cli_get_volume] 0-glusterd: Received get vol req
[2011-10-05 15:54:27.890036] I [glusterd-handler.c:831:glusterd_handle_cli_get_volume] 0-glusterd: Received get vol req
[2011-10-05 15:56:20.449829] I [glusterd-volume-ops.c:78:glusterd_handle_create_volume] 0-glusterd: Received create volume req
[2011-10-05 15:56:20.545578] I [glusterd-utils.c:258:glusterd_lock] 0-glusterd: Cluster lock held by ccb505fb-79fc-46e1-8d65-79bc8dab982e
[2011-10-05 15:56:20.545615] I [glusterd-handler.c:438:glusterd_op_txn_begin] 0-management: Acquired local lock
[2011-10-05 15:56:20.605119] I [glusterd-rpc-ops.c:847:glusterd3_1_cluster_lock_cbk] 0-glusterd: Received ACC from uuid: b1d03c01-cdc4-4395-9a83-5fe467f02ecc
[2011-10-05 15:56:20.605204] I [glusterd-rpc-ops.c:847:glusterd3_1_cluster_lock_cbk] 0-glusterd: Received ACC from uuid: a407e13b-e4de-4c02-8eb4-d7f982f1f1cf
[2011-10-05 15:56:20.615849] I [glusterd-op-sm.c:1611:glusterd_op_ac_send_stage_op] 0-glusterd: Sent op req to 2 peers
[2011-10-05 15:56:20.704636] I [glusterd-rpc-ops.c:1176:glusterd3_1_stage_op_cbk] 0-glusterd: Received ACC from uuid: a407e13b-e4de-4c02-8eb4-d7f982f1f1cf
[2011-10-05 15:56:21.118781] I [glusterd-rpc-ops.c:1176:glusterd3_1_stage_op_cbk] 0-glusterd: Received ACC from uuid: b1d03c01-cdc4-4395-9a83-5fe467f02ecc
[2011-10-05 15:56:21.543915] I [glusterd-op-sm.c:1725:glusterd_op_ac_send_commit_op] 0-glusterd: Sent op req to 2 peers
[2011-10-05 15:56:21.624977] I [glusterd-rpc-ops.c:1477:glusterd3_1_commit_op_cbk] 0-glusterd: Received RJT from uuid: a407e13b-e4de-4c02-8eb4-d7f982f1f1cf
[2011-10-05 15:56:23.173091] I [glusterd-rpc-ops.c:1477:glusterd3_1_commit_op_cbk] 0-glusterd: Received ACC from uuid: b1d03c01-cdc4-4395-9a83-5fe467f02ecc
[2011-10-05 15:56:23.173697] I [glusterd-rpc-ops.c:906:glusterd3_1_cluster_unlock_cbk] 0-glusterd: Received ACC from uuid: a407e13b-e4de-4c02-8eb4-d7f982f1f1cf
[2011-10-05 15:56:23.174671] I [glusterd-rpc-ops.c:906:glusterd3_1_cluster_unlock_cbk] 0-glusterd: Received ACC from uuid: b1d03c01-cdc4-4395-9a83-5fe467f02ecc
[2011-10-05 15:56:23.174705] I [glusterd-op-sm.c:2014:glusterd_op_txn_complete] 0-glusterd: Cleared local lock

================================================================================
Comment 1 krishnan parthasarathi 2011-10-05 21:49:42 EDT
Shylesh, Could you attach the logs of the glusterd which sent RJT during the create volume operation? This will tell us why create volume failed in commit phase? Failure of operations during commit phase (generally) aren't rolled back. This is a known issue.
Comment 2 shylesh 2011-10-06 22:57:44 EDT

*** This bug has been marked as a duplicate of bug 3702 ***

Note You need to log in before you can comment on or make changes to this bug.