Bug 765428 - (GLUSTER-3696) Some times not able to create volume and cannot add bricks
Some times not able to create volume and cannot add bricks
Status: CLOSED DUPLICATE of bug 765434
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
pre-release
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: krishnan parthasarathi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-05 04:20 EDT by shylesh
Modified: 2015-11-03 18:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description shylesh 2011-10-05 01:57:47 EDT
1. Created some volumes 
2. did some rebalance operations
3. Later could not add bricks to replicate volume 
error message " operation failed on 192.168.2.26" which is one of the peer.
4. new Volume creation also fails with the message "Failed to store the volume information"

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

[root@GVSA-GMCQA1 mnt]# tail -f  /var/log/glusterfs/etc-glusterfs-glusterd.vol.log 
[2011-10-05 13:48:26.162421] I [glusterd-utils.c:214:glusterd_is_local_addr] 0-glusterd: 192.168.2.26 is local
[2011-10-05 13:48:26.162599] I [glusterd-utils.c:214:glusterd_is_local_addr] 0-glusterd: 192.168.2.26 is local
[2011-10-05 13:48:26.162981] I [glusterd-utils.c:795:glusterd_volume_brickinfo_get_by_brick] 0-: brick: 192.168.2.45:/repli2
[2011-10-05 13:48:26.163051] I [glusterd-handler.c:1308:glusterd_op_stage_send_resp] 0-glusterd: Responded to stage, ret: 0
[2011-10-05 13:48:27.282707] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:28.284785] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:28.284897] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (Connection refused)
[2011-10-05 13:48:30.287432] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:31.288321] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:31.288409] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (Connection refused)
[2011-10-05 13:48:33.291990] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:33.409079] I [glusterd-handler.c:516:glusterd_req_ctx_create] 0-glusterd: Received op from uuid: c4c05d0f-1a2b-4c19-8afa-d9e816c906f3
[2011-10-05 13:48:33.409377] I [glusterd-utils.c:214:glusterd_is_local_addr] 0-glusterd: 192.168.2.26 is local
[2011-10-05 13:48:33.412120] I [glusterd-utils.c:214:glusterd_is_local_addr] 0-glusterd: 192.168.2.26 is local
[2011-10-05 13:48:33.412154] I [glusterd-utils.c:746:glusterd_volume_brickinfo_get] 0-management: Found brick
[2011-10-05 13:48:33.412174] I [glusterd-utils.c:746:glusterd_volume_brickinfo_get] 0-management: Found brick
[2011-10-05 13:48:33.412323] I [glusterd-utils.c:214:glusterd_is_local_addr] 0-glusterd: 192.168.2.26 is local
[2011-10-05 13:48:33.412351] I [glusterd-utils.c:746:glusterd_volume_brickinfo_get] 0-management: Found brick
[2011-10-05 13:48:33.412369] I [glusterd-utils.c:746:glusterd_volume_brickinfo_get] 0-management: Found brick
[2011-10-05 13:48:33.412535] I [glusterd-utils.c:214:glusterd_is_local_addr] 0-glusterd: 192.168.2.26 is local
[2011-10-05 13:48:33.412566] I [glusterd-utils.c:746:glusterd_volume_brickinfo_get] 0-management: Found brick
[2011-10-05 13:48:33.412585] I [glusterd-utils.c:746:glusterd_volume_brickinfo_get] 0-management: Found brick
[2011-10-05 13:48:33.412729] I [glusterd-utils.c:214:glusterd_is_local_addr] 0-glusterd: 192.168.2.26 is local
[2011-10-05 13:48:33.412776] I [glusterd-utils.c:746:glusterd_volume_brickinfo_get] 0-management: Found brick
[2011-10-05 13:48:33.412795] I [glusterd-utils.c:746:glusterd_volume_brickinfo_get] 0-management: Found brick
[2011-10-05 13:48:33.414054] I [glusterd-utils.c:795:glusterd_volume_brickinfo_get_by_brick] 0-: brick: 192.168.2.26:/export/sdd/repli2
[2011-10-05 13:48:33.414925] I [glusterd-utils.c:214:glusterd_is_local_addr] 0-glusterd: 192.168.2.26 is local
[2011-10-05 13:48:33.414961] I [glusterd-utils.c:746:glusterd_volume_brickinfo_get] 0-management: Found brick
[2011-10-05 13:48:33.419186] I [glusterd-utils.c:1128:glusterd_volume_start_glusterfs] 0-: About to start glusterfs for brick 192.168.2.26:/export/sdd/repli2
[2011-10-05 13:48:33.452949] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:33.453037] I [glusterd-utils.c:795:glusterd_volume_brickinfo_get_by_brick] 0-: brick: 192.168.2.45:/repli2
[2011-10-05 13:48:33.453067] I [glusterd-utils.c:746:glusterd_volume_brickinfo_get] 0-management: Found brick
[2011-10-05 13:48:33.456197] E [glusterd-utils.c:1371:glusterd_volume_compute_cksum] 0-management: failed to sort file /etc/glusterd/vols/vol-replicate/info to /tmp/vol-replicate.0B78tz
[2011-10-05 13:48:33.456263] E [glusterd-op-sm.c:2154:glusterd_op_ac_commit_op] 0-: Commit failed: -1
[2011-10-05 13:48:33.456353] I [glusterd-handler.c:1349:glusterd_op_commit_send_resp] 0-glusterd: Responded to commit, ret: 0
[2011-10-05 13:48:34.294767] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:34.294874] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (Connection refused)
[2011-10-05 13:48:36.298477] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:37.300260] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:37.300351] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:37.300404] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (Connection refused)
[2011-10-05 13:48:39.303904] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:40.305790] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:40.305912] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:40.305980] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (Connection refused)
[2011-10-05 13:48:42.309283] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:43.99715] I [glusterd-handler.c:1258:glusterd_handle_cluster_unlock] 0-glusterd: Received UNLOCK from uuid: c4c05d0f-1a2b-4c19-8afa-d9e816c906f3
[2011-10-05 13:48:43.99854] I [glusterd-handler.c:1235:glusterd_op_unlock_send_resp] 0-glusterd: Responded to unlock, ret: 0
[2011-10-05 13:48:43.311098] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:43.311159] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:43.311198] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (Connection refused)
[2011-10-05 13:48:45.314726] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:46.316503] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:46.316597] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:46.316658] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (Connection refused)
[2011-10-05 13:48:48.319133] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:49.320930] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:49.321010] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:49.321051] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (Connection refused)
[2011-10-05 13:48:51.323544] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:52.324335] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:48:52.324434] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:51:13.29940] I [glusterd-handler.c:476:glusterd_handle_cluster_lock] 0-glusterd: Received LOCK from uuid: c4c05d0f-1a2b-4c19-8afa-d9e816c906f3
[2011-10-05 13:51:13.30036] I [glusterd-utils.c:258:glusterd_lock] 0-glusterd: Cluster lock held by c4c05d0f-1a2b-4c19-8afa-d9e816c906f3
[2011-10-05 13:51:13.30103] I [glusterd-handler.c:1215:glusterd_op_lock_send_resp] 0-glusterd: Responded, ret: 0
[2011-10-05 13:51:13.42203] I [glusterd-handler.c:516:glusterd_req_ctx_create] 0-glusterd: Received op from uuid: c4c05d0f-1a2b-4c19-8afa-d9e816c906f3
[2011-10-05 13:51:13.107314] I [glusterd-utils.c:214:glusterd_is_local_addr] 0-glusterd: 192.168.2.26 is local
[2011-10-05 13:51:13.108063] I [glusterd-handler.c:1308:glusterd_op_stage_send_resp] 0-glusterd: Responded to stage, ret: 0
[2011-10-05 13:51:13.545776] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:51:13.545869] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:51:13.545931] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (Connection refused)
[2011-10-05 13:51:13.776972] I [glusterd-handler.c:516:glusterd_req_ctx_create] 0-glusterd: Received op from uuid: c4c05d0f-1a2b-4c19-8afa-d9e816c906f3
[2011-10-05 13:51:13.777312] I [glusterd-utils.c:214:glusterd_is_local_addr] 0-glusterd: 192.168.2.26 is local
[2011-10-05 13:51:13.818128] E [glusterd-utils.c:1371:glusterd_volume_compute_cksum] 0-management: failed to sort file /etc/glusterd/vols/test/info to /tmp/test.SAergn
[2011-10-05 13:51:13.818372] I [glusterd-store.c:965:glusterd_store_delete_volume] 0-: Removed info
[2011-10-05 13:51:13.818414] I [glusterd-store.c:965:glusterd_store_delete_volume] 0-: Removed cksum
[2011-10-05 13:51:13.818451] I [glusterd-store.c:965:glusterd_store_delete_volume] 0-: Removed rbstate
[2011-10-05 13:51:13.818537] E [glusterd-op-sm.c:2154:glusterd_op_ac_commit_op] 0-: Commit failed: -1
[2011-10-05 13:51:13.818845] I [glusterd-handler.c:1349:glusterd_op_commit_send_resp] 0-glusterd: Responded to commit, ret: 0
[2011-10-05 13:51:13.834221] I [glusterd-handler.c:1258:glusterd_handle_cluster_unlock] 0-glusterd: Received UNLOCK from uuid: c4c05d0f-1a2b-4c19-8afa-d9e816c906f3
[2011-10-05 13:51:13.834550] I [glusterd-handler.c:1235:glusterd_op_unlock_send_resp] 0-glusterd: Responded to unlock, ret: 0
[2011-10-05 13:51:15.550503] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:51:16.552266] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:51:16.552377] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:51:16.552444] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (Connection refused)
[2011-10-05 13:51:18.555938] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:51:19.557741] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:51:19.557836] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:51:19.557882] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (Connection refused)
[2011-10-05 13:51:21.561112] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)
[2011-10-05 13:51:22.562804] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (No such file or directory)

[2011-10-05 13:48:52.324508] E [socket.c:2110:socket_connect] 0-management: connection attempt failed (Connection refused)
Comment 1 shylesh 2011-10-05 02:00:16 EDT
Actually operations are succeeded , i.e. volumes are getting crated , bricks are added but only error messages are shown .
Comment 2 shylesh 2011-10-05 04:20:59 EDT

    
Comment 3 krishnan parthasarathi 2011-10-13 04:48:44 EDT

*** This bug has been marked as a duplicate of bug 3702 ***

Note You need to log in before you can comment on or make changes to this bug.