Bug 765460 - (GLUSTER-3728) stripe:core with posix compliance test on stripe volume
stripe:core with posix compliance test on stripe volume
Status: CLOSED DUPLICATE of bug 765304
Product: GlusterFS
Classification: Community
Component: stripe (Show other bugs)
pre-release
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: shishir gowda
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-17 05:09 EDT by Saurabh
Modified: 2013-12-08 20:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: nfs
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2011-10-17 05:09:07 EDT
[root@RHEL6 ~]# /opt/glusterfs/3.2.4/sbin/glusterfs -V
glusterfs 3.2.4 built on Oct 10 2011 10:33:37
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.

[root@RHEL6 ~]# /opt/glusterfs/3.2.4/sbin/gluster volume info stripe-vol

Volume Name: stripe-vol
Type: Stripe
Status: Started
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: 10.1.11.130:/export/stripe1
Brick2: 10.1.11.131:/export/stripe1
[root@RHEL6 ~]# 


(gdb) bt
#0  0x00000034c2232905 in raise () from /lib64/libc.so.6
#1  0x00000034c22340e5 in abort () from /lib64/libc.so.6
#2  0x00000034c226f827 in __libc_message () from /lib64/libc.so.6
#3  0x00000034c22ff397 in __fortify_fail () from /lib64/libc.so.6
#4  0x00000034c22fd280 in __chk_fail () from /lib64/libc.so.6
#5  0x00007f7e8528f65a in strcpy (nfl=0x7f7e850f1eac, inode=<value optimized out>, parent=0x7f7e82d1a0c0, newparent=0x0, 
    name=0x7f7e7c09309a "_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789"..., newname=0x0)
    at /usr/include/bits/string3.h:105
#6  nfl_inodes_init (nfl=0x7f7e850f1eac, inode=<value optimized out>, parent=0x7f7e82d1a0c0, newparent=0x0, 
    name=0x7f7e7c09309a "_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789_123456789"..., newname=0x0) at nfs-inodes.c:60
#7  0x00007f7e852900bd in nfs_inode_create (nfsx=0x15a1e10, xl=0x15a9c10, nfu=0x7fff753707d0, pathloc=0x7f7e822c35a8, flags=2, 
    mode=420, cbk=0x7f7e85299d40 <nfs3svc_create_cbk>, local=0x7f7e822c3180) at nfs-inodes.c:128
#8  0x00007f7e8529602e in nfs3_create_exclusive (cs=0x7f7e822c3180) at nfs3.c:2457
#9  0x00007f7e85299b38 in nfs3_create_resume (carg=0x7f7e822c3180) at nfs3.c:2479
#10 0x00007f7e852a4aec in nfs3_fh_resolve_entry_lookup_cbk (frame=<value optimized out>, cookie=<value optimized out>, 
    this=<value optimized out>, op_ret=<value optimized out>, op_errno=<value optimized out>, inode=<value optimized out>, 
    buf=0x7f7e7c093328, xattr=0x0, postparent=0x7f7e7c0934e8) at nfs3-helpers.c:2506
#11 0x00007f7e8528c249 in nfs_fop_lookup_cbk (frame=0x7f7e874ba448, cookie=<value optimized out>, this=<value optimized out>, 
    op_ret=<value optimized out>, op_errno=<value optimized out>, inode=<value optimized out>, buf=0x7f7e7c093328, xattr=0x0, 
    postparent=0x7f7e7c0934e8) at nfs-fops.c:318
#12 0x00007f7e85b7217b in io_stats_lookup_cbk (frame=0x7f7e8772435c, cookie=<value optimized out>, this=<value optimized out>, 
    op_ret=-1, op_errno=2, inode=0x0, buf=0x7f7e7c093328, xattr=0x0, postparent=0x7f7e7c0934e8) at io-stats.c:1391
#13 0x00007f7e85d88d2e in qr_lookup_cbk (frame=0x7f7e87724400, cookie=<value optimized out>, this=<value optimized out>, op_ret=-1, 
    op_errno=2, inode=0x0, buf=0x7f7e7c093328, dict=0x0, postparent=0x7f7e7c0934e8) at quick-read.c:439
#14 0x00007f7e85f9bb45 in ioc_lookup_cbk (frame=0x7f7e877244a4, cookie=<value optimized out>, this=<value optimized out>, op_ret=-1, 
    op_errno=2, inode=0x0, stbuf=0x7f7e7c093328, dict=0x0, postparent=0x7f7e7c0934e8) at io-cache.c:265
#15 0x00007f7e8866d92b in default_lookup_cbk (frame=0x7f7e87724548, cookie=<value optimized out>, this=<value optimized out>, 
---Type <return> to continue, or q <return> to quit---
    op_ret=-1, op_errno=<value optimized out>, inode=<value optimized out>, buf=0x7f7e7c093328, dict=0x0, postparent=0x7f7e7c0934e8)
    at defaults.c:46
#16 0x00007f7e8866d92b in default_lookup_cbk (frame=0x7f7e87725174, cookie=<value optimized out>, this=<value optimized out>, 
    op_ret=-1, op_errno=<value optimized out>, inode=<value optimized out>, buf=0x7f7e7c093328, dict=0x0, postparent=0x7f7e7c0934e8)
    at defaults.c:46
#17 0x00007f7e865d6003 in stripe_lookup_cbk (frame=0x7f7e877245ec, cookie=<value optimized out>, this=<value optimized out>, 
    op_ret=<value optimized out>, op_errno=<value optimized out>, inode=<value optimized out>, buf=0x7fff75370d90, dict=0x0, 
    postparent=0x7fff75370d20) at stripe.c:390
#18 0x00007f7e867faef0 in client3_1_lookup_cbk (req=<value optimized out>, iov=<value optimized out>, count=<value optimized out>, 
    myframe=0x7f7e87724c54) at client3_1-fops.c:2233
#19 0x00007f7e8843c365 in rpc_clnt_handle_reply (clnt=0x161f2b0, pollin=0x16215c0) at rpc-clnt.c:741
#20 0x00007f7e8843c5b9 in rpc_clnt_notify (trans=<value optimized out>, mydata=0x161f2e0, event=<value optimized out>, 
    data=<value optimized out>) at rpc-clnt.c:854
#21 0x00007f7e88437458 in rpc_transport_notify (this=<value optimized out>, event=<value optimized out>, data=<value optimized out>)
    at rpc-transport.c:919
#22 0x00007f7e81d7d254 in socket_event_poll_in (this=0x161f420) at socket.c:1647
#23 0x00007f7e81d7d337 in socket_event_handler (fd=<value optimized out>, idx=11, data=0x161f420, poll_in=1, poll_out=0, 
    poll_err=<value optimized out>) at socket.c:1762
#24 0x00007f7e88683504 in event_dispatch_epoll_handler (event_pool=0x159c360) at event.c:794
#25 event_dispatch_epoll (event_pool=0x159c360) at event.c:856
#26 0x0000000000405e99 in main (argc=7, argv=0x7fff753710f8) at glusterfsd.c:1509
(gdb)
Comment 1 Rahul C S 2011-10-18 00:22:38 EDT

*** This bug has been marked as a duplicate of bug 3572 ***

Note You need to log in before you can comment on or make changes to this bug.