Bug 765543 - (GLUSTER-3811) gluster volume set error for nfs.export-dir
gluster volume set error for nfs.export-dir
Status: CLOSED WORKSFORME
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.2.4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: krishnan parthasarathi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-14 05:43 EST by Anush Shetty
Modified: 2015-11-03 18:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-27 07:34:31 EST
Type: ---
Regression: RTA
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2011-11-14 05:43:11 EST
It tried setting the export-dir as
[root@RHEL6 nfs]# gluster volume set vol nfs.export-dir on
Set volume successful

[root@RHEL6 nfs]# showmount -e 10.1.11.108
Export list for 10.1.11.108:
/volon *

And even when I tried mounting it, I got errors.

[root@RHEL6 ~]# mount -o vers=3 10.1.11.108:/volon /mnt/hgfs/
mount.nfs: Remote I/O error

This is the issue when I set the export-dir without using a / in the beginning of the dir name.
Comment 1 krishnan parthasarathi 2011-11-14 20:24:37 EST
Anush, 
Please attach the glusterd log file(s).
Comment 2 Amar Tumballi 2012-02-27 07:22:43 EST
Anush, please do the needful. Before that, confirm if the issue exists on master branch now.
Comment 3 Anush Shetty 2012-02-27 07:34:31 EST
I don't see this issue in 3.3.0qa24. So closing it.

Note You need to log in before you can comment on or make changes to this bug.