Bug 765555 - (GLUSTER-3823) Add command-line support for enforce-quorum option
Add command-line support for enforce-quorum option
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
pre-release
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-21 12:49 EST by Jeff Darcy
Modified: 2013-12-18 19:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Darcy 2011-11-21 12:49:32 EST
Now that it's a feature in the code, might as well provide an easy way to enable it.  Still NO_DOC, though, since we don't necessarily want people changing it without being briefed on the implications.
Comment 1 Vijay Bellur 2011-11-22 08:44:31 EST
How about making quorum count configurable too?
Comment 2 Jeff Darcy 2011-11-22 09:10:24 EST
(In reply to comment #1)
> How about making quorum count configurable too?

What would the options be?  Quorum count (Q) is already determined algorithmically, based on the total replica count (R).  Let's examine the cases.

* Q=1 is equivalent to no quorum enforcement, except that writers get EROFS instead of EIO.  Not sure if this is useful.

* Q=2, R=2 (i.e. no special case for first brick) seems marginally useful.

* Q=2, R=3 is what we already get for any R=3.

* Q=3, R=3 also seems marginally useful.

* R>3 will remain too rare to worry about.

So both of the marginally useful cases require unanimity.  Would it make more sense to have a separate quorum-count option, or allow enforce-quorum (quorum-type) to have more than two values?

* "none" = no enforcement

* "majority" = what's there now

* "all" = require presence of all servers
Comment 3 Anand Avati 2011-11-28 08:46:35 EST
CHANGE: http://review.gluster.com/743 (Change-Id: Ia52ddb551e24c27969f7f5fa0f94c1044789731f) merged in master by Vijay Bellur (vijay@gluster.com)

Note You need to log in before you can comment on or make changes to this bug.