Bug 76558 - TB: neat:388:hydrateDevices -> existing ~/pixmaps
TB: neat:388:hydrateDevices -> existing ~/pixmaps
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
8.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: 86560
  Show dependency treegraph
 
Reported: 2002-10-23 09:35 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-29 11:49:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-23 09:35:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
If I go to System Settings -> Network, then enter the root password, I get an
"Exception Occured" dialog.  I can run neat or redhat-config-network from bash
and it works fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. From the RedHat Menu, select System Settings -> Network
2. Enter root password

Actual Results:  An "Exception Occured" dialog pops up.

Expected Results:  The application should have started.

Additional info:

Traceback (most recent call last):
  File "/usr/sbin/neat", line 1508, in ?
    window = mainDialog()
  File "/usr/sbin/neat", line 238, in __init__
    self.hydrate()
  File "/usr/sbin/neat", line 341, in hydrate
    self.hydrateDevices()
  File "/usr/sbin/neat", line 388, in hydrateDevices
    clist.set_pixtext(row, STATUS_COLUMN, status, 5, status_pixmap, status_mask)
TypeError: GtkCList.set_pixtext() argument 6 must be gtk.gdk.Pixmap, not None
Comment 1 Harald Hoyer 2002-10-24 04:26:57 EDT
this looks like your installation of redhat-config-network is incomplete.
Please run:
# rpm -V redhat-config-network && echo "Seems to be ok"
Comment 2 Need Real Name 2002-10-24 09:37:37 EDT
When I run

rpm -V redhat-config-network

I get a list of 51 lines like this:

S.5....T   /usr/share/redhat-config-network/netconfpkg/Control.pyc

All of them referring to .pyc files.

I uninstalled and reinstalled redhat-config-network.  Immediately after the
install, running "rpm -V redhat-config-network" gave no output.  I tried using
"System Settings -> Network" and I got the same problem (same traceback).  Then,
running "rpm -V redhat-config-network" gave the same list of .pyc files.

"rpm -V python-2.2.1-17" gives no output.
Comment 3 Harald Hoyer 2002-10-24 09:42:00 EDT
and you have Red Hat Linux 8.0 and which version of redhat-config-network?
Comment 4 Need Real Name 2002-10-24 09:46:21 EDT
redhat-config-network-1.1.20-1
Comment 5 gene smith 2002-12-23 14:06:27 EST
I am running completely up-2-date'd 7.2. When I click on hardware add or edit I
get this:


Please visit http://bugzilla.redhat.com/bugzilla/ !
File a bug against component redhat-config-network. Thank you!

Traceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 1058, in on_hardwareEditButton_clicked
    self.showHardwareDialog(type, true)
  File "/usr/sbin/neat", line 1079, in showHardwareDialog
    dialog = ethernetHardwareDialog(hw)
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py",
line 75, in __init__
    self.setup()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py",
line 140, in setup
    list.append(modInfo[i]['description'])
KeyError: description
Comment 6 gene smith 2002-12-23 22:57:07 EST
Similar problem reported in bug 80287
Comment 7 Harald Hoyer 2003-01-13 08:03:13 EST
seems like some pixmaps are missing or your pygtk2 is strange
which version of pygtk2 do you have?
do 
/usr/share/redhat-config-network/pixmaps/off.xpm
/usr/share/redhat-config-network/pixmaps/on.xpm
exist?
Comment 8 Need Real Name 2003-01-21 00:23:30 EST
/usr/share/redhat-config-network/pixmaps/off.xpm and
/usr/share/redhat-config-network/pixmaps/on.xpm exist and appear valid.

I have pygtk2-1.99.12-7

I tried rpm -V pygtk2-1.99.12-7

and got no output.
Comment 9 tom hynes 2003-01-26 01:32:07 EST
7.2 All updates Dell Optiplex 386 550 mhz 3c905b 100basetx (cyclone)
/2raceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 1058, in on_hardwareEditButton_clicked
    self.showHardwareDialog(type, true)
  File "/usr/sbin/neat", line 1079, in showHardwareDialog
    dialog = ethernetHardwareDialog(hw)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py", line 75, in __init__
    self.setup()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/ethernethardware.py", line 140, in setup
    list.append(modInfo[i]['description'])
KeyError: description

Local variables in innermost frame:
modInfo: <netconfpkg.Conf.ConfModInfo instance at 84bd378>
list: ['RealTek RTL8129', 'Raytheon Raylink/WebGear/Aviator PCMCIA wireless', 'SMC Ultra32 EISA', 'DEC 21*40 and clones', 'Lucent Orinoco/Melco 
PCMCIA wireless (alternate)', 'SMC 91c92 series PCMCIA', 'Aironet 4500 PCI-ISA-i365 wireless', 'Intel EtherExpress/1000', 'PCI NE2000 clones', 
'MiCom-Interlan NI5010', '3Com 3c515 Corkscrew', 'SMC 83c170 EPIC/100', 'NI5210 ethernet', 'AT1500, HP J2405A, most NE2100/clone', 'MyriCOM 
MyriNET SBUS', '3Com EtherLink16', 'AT&T/Lucent/Hitachi ISA WaveLAN', 'SiS 900/7016CI', 'Cabletron E2100', 'NE1000, NE2000, and compatible', 'Intel 
EtherExpress Pro 100B', 'Allied Telesis AT1700', 'Greenwigh GIrBIL IrDA', 'Older DEC 21040, most 21*40', 'NSC IrDA', 'Sun Quad', 'ICL EtherTeam 16i/32 
EISA', '3Com 3c590/3c595/3c90x/3cx980', '3Com 3c589 series PCMCIA', 'Sun BigMac', 'ThunderLAN', '3Com 3c574 series PCMCIA', 'Ansel 
Communications Model 3200', 'Aironet 4500 PCMCIA wireless', 'Xircom CBE-100 CardBus', 'General Instruments SB1000']
self: <netconfpkg.gui.ethernethardware.ethernetHardwareDialog instance at 84af830>
i: defxx

Comment 10 Harald Hoyer 2003-01-27 06:44:19 EST
tom hynes: please check next time, that you report bugs seperately, if it
differs. You posted a duplicate of bug 75381.
Comment 11 Harald Hoyer 2003-03-25 05:49:25 EST
vcato@bellsouth.net: I never heard of a problem similar to yours... You must
have mixed some gtk/python issues in here... Are you sure you did not pollute
your system with non-redhat packages that could have caused your problems?
Comment 12 Need Real Name 2003-04-01 01:34:05 EST
I found the source of the problem.  I have a directory in my home directory
called pixmaps that has a file called on.xpm.  For some reason, when neat is run
from the kde menu, it is picking up this file instead of
/usr/share/redhat-config-network/pixmaps/on.xpm

If I change the name of ~/pixmaps to something else, neat works fine.  Must be
some kind of pixmap search path issue.
Comment 13 Harald Hoyer 2003-04-01 04:29:29 EST
wow... cool, now I know how to prevent such unwanted behaviour :) Thank you very
much for hunting down the problem.

Note You need to log in before you can comment on or make changes to this bug.