This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 765769 - [abrt] kernel: BUG: sleeping function called from invalid context at kernel/mutex.c:85
[abrt] kernel: BUG: sleeping function called from invalid context at kernel/m...
Status: CLOSED DUPLICATE of bug 727952
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:9ef5e571b32e4691bd403807151...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-09 06:28 EST by Marcus Ilgner
Modified: 2012-04-11 11:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 11:49:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: smolt_data (4.53 KB, text/plain)
2011-12-09 06:28 EST, Marcus Ilgner
no flags Details

  None (edit)
Description Marcus Ilgner 2011-12-09 06:28:30 EST
libreport version: 2.0.7
cmdline:        ro root=/dev/mapper/vg_milgner-lv_root rd_LVM_LV=vg_milgner/lv_root rd_LVM_LV=vg_milgner/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=dvorak rhgb quiet
kernel:         2.6.40.6-0.fc15.x86_64
reason:         BUG: sleeping function called from invalid context at kernel/mutex.c:85
time:           Thu 03 Nov 2011 09:40:25 AM CET

smolt_data:     Text file, 4634 bytes

backtrace:
:BUG: sleeping function called from invalid context at kernel/mutex.c:85
:in_atomic(): 0, irqs_disabled(): 1, pid: 1637, name: pm-suspend
:Pid: 1637, comm: pm-suspend Not tainted 2.6.40.6-0.fc15.x86_64 #1
:Call Trace:
: [<ffffffff81047514>] __might_sleep+0xeb/0xf0
: [<ffffffff814878f9>] mutex_lock+0x24/0x4a
: [<ffffffff8148858a>] ? _raw_spin_lock_irqsave+0x12/0x2f
: [<ffffffff810adcaf>] irq_reserve_irqs+0x3a/0x85
: [<ffffffff810affee>] irq_set_chip+0x58/0x62
: [<ffffffff810b0370>] ? handle_fasteoi_irq+0x9b/0x9b
: [<ffffffff810b04a0>] irq_set_chip_and_handler_name+0x1e/0x37
: [<ffffffff81023e35>] arch_setup_hpet_msi+0xc0/0xce
: [<ffffffff81027a19>] hpet_setup_msi_irq+0x19/0x31
: [<ffffffff81027df5>] hpet_set_mode+0x111/0x15f
: [<ffffffff81027e57>] hpet_msi_set_mode+0x14/0x16
: [<ffffffff8107cd64>] clockevents_set_mode+0x20/0x4d
: [<ffffffff8107d493>] tick_notify+0x337/0x37c
: [<ffffffff8147fab8>] ? printk+0x51/0x53
: [<ffffffff8148b93e>] notifier_call_chain+0x37/0x63
: [<ffffffff810748e0>] raw_notifier_call_chain+0x14/0x16
: [<ffffffff8107caab>] clockevents_notify+0x3a/0xf9
: [<ffffffff810788bc>] timekeeping_resume+0xca/0xd8
: [<ffffffff812f87ec>] syscore_resume+0x6b/0xb3
: [<ffffffff8108997f>] suspend_devices_and_enter+0x14d/0x1d9
: [<ffffffff81089aeb>] enter_state+0xe0/0x137
: [<ffffffff81089166>] state_store+0xaf/0xc5
: [<ffffffff8123822b>] kobj_attr_store+0x17/0x19
: [<ffffffff811803c0>] sysfs_write_file+0x111/0x14d
: [<ffffffff8112744d>] vfs_write+0xac/0xf3
: [<ffffffff8112763c>] sys_write+0x4a/0x6e
: [<ffffffff8148ed02>] system_call_fastpath+0x16/0x1b

event_log:
:2011-12-09-12:26:56> Smolt profile successfully saved
:2011-12-09-12:27:19> Submitting oops report to http://submit.kerneloops.org/submitoops.php
:2011-12-09-12:28:23  Kernel oops has not been sent due to Couldn't connect to server
:2011-12-09-12:28:23* (exited with 1)
Comment 1 Marcus Ilgner 2011-12-09 06:28:34 EST
Created attachment 544489 [details]
File: smolt_data
Comment 2 Dave Jones 2012-04-11 11:49:04 EDT

*** This bug has been marked as a duplicate of bug 727952 ***

Note You need to log in before you can comment on or make changes to this bug.